Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am creating my resume in LaTeX and loving it, using new commands and learning many new things. However I am stuck at the top. I am trying to create an output like this ..

enter image description here

I have learnt a bit about indentation and have to learn more about using the geometry package but during my coding (below) I am not able to align like the above image. I have used \noindent and \flushright but each time I use the command the indentation starts with new line making the output different.

enter image description here

%% (c) Shashwat Pant
%% Resume - C.V of Shashwat Pant
%% September 17th 2012

\documentclass[letterpaper,11pt]{article}
%\usepackage{times}
\usepackage{geometry}
\usepackage{hyperref}
\usepackage[empty]{fullpage}

\newcommand{\head}[1]{\noindent \\ \\ \large \bf #1}

\begin{document}

\begin{center}
\bf{\huge Shashwat Pant}\    \end{center}

\hrule

\head{Contact Information}

\begin{center} {

 Address    
} \end{center}

\begin{flushright}
  Voice -

 \end{flushright}

\end{document}

Apart from the indentation issue, what font package is good for making resume ?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

You can use minipages:

%% (c) Shashwat Pant
%% Resume - C.V of Shashwat Pant
%% September 17th 2012

\documentclass[letterpaper,11pt]{article}
%\usepackage[charter]{mathdesign}
% \usepackage{charter}
% \usepackage{mathpazo}
\usepackage{kpfonts}
\usepackage{geometry}
\usepackage{hyperref}
\usepackage[empty]{fullpage}

\newcommand{\head}[1]{\noindent \\ \large \bf #1}

\begin{document}

\begin{center}
\bf{\huge Shashwat Pant}\    \end{center}

\hrule
\begin{minipage}[c]{.15\textwidth}
\head{Contact Information}
\end{minipage}%
\hfill
\begin{minipage}[t]{.3\textwidth}
Address line 1 \    Line 2 \    Line 3 \    Line 4 \    Line 5
\end{minipage}%
\hfill
\begin{minipage}[c]{.3\textwidth}
  Voice -
\end{minipage}%

\end{document}

For fonts I have added few choices. Which one is better is a very subjective matter. I prefer charter or palatino or kpfonts.

share|improve this answer
    
Thanks! Was really helpful, will get the minipage under my belt asap. Other than that if i don't use minipage in the Contact Information field and tried using it on the other two, all the text appears to be bold ? Any guess why ? –  Shashwat Sep 17 '12 at 13:58
    
@Shashwat Your \title (\newcommand{\head}[1]{\noindent \\ \large \bf #1} is defined to be bold. If you use it within minipage it is applicable only inside. Removing minipage leaves the command \bf open and every thing after that will become bold. –  Harish Kumar Sep 17 '12 at 14:01
    
But I am not including the other text under my \title command, so why it is considering the other 2 minipage as input ? Is there a way to create a new scope for contact information without using minipage for the first yet keeping the other 2 in minipage while keeping the font normal ? –  Shashwat Sep 17 '12 at 14:04
    
@Shashwat: Effect of \bf will be felt outside the \head command also unless you put inside a group. For example put extra set of braces as in \newcommand{\head}[1]{\par {\large \bf #1}} and see the effect. –  Harish Kumar Sep 17 '12 at 14:09
    
Could you please remove the image/address. I don't want to put in on internet. Thanks –  Shashwat Jun 24 at 12:00

Another option would be to use tabular-like environments; in the following example I used tabular environments inside a tabularx:

\documentclass[letterpaper,11pt,draft]{article}
\usepackage{tabularx}
\usepackage{booktabs}

\begin{document}

\noindent
\begin{tabularx}{\linewidth}{@{}>{\bfseries}XlX@{}}
\multicolumn{3}{@{}l}{\huge\bfseries Shashwat Pant} 
\\ \toprule
Contact Information
& 
{
\begin{tabular}[t]{@{}l@{}}
Address line 1 \\
Address line 2 \\
Address line 3 \\
Address line 4 \\
Address line 5
\end{tabular}
}
&
{
\begin{tabular}[t]{@{}l@{}l@{}}
  Voice: & \texttt{+}000 99 999 99 \\
  Email: & \texttt{email@gmail.com} \\
  Twitter: & \texttt{shashpant} \\
  GitHub: & \texttt{shashpant}
\end{tabular}
}
\\
\end{tabularx}

\end{document}

enter image description here

Unrelated, but useful: never use two consecutive line changing commands \\ \\ (this will produce underfull boxes warnings); instead of the old \bf form, one should use \bfseries in modern LaTeX documents.

share|improve this answer
    
Thanks, I was looking at tabular representation but can't get hold of some syntax, I prefer to learn the command before implementing so can you please point to some good tabularx document. Other than that when I compile your code I get an awkward placement of the text> I'd really love to use this code, however the awkward alignment and lack of my geometry class knowledge makes it worse. Image/Screenshot i.imgur.com/zDCgX.png –  Shashwat Sep 17 '12 at 13:54
    
@Shashwat of course; the tabularx package documentation contains the description of the relevant features. Regarding the problem with your actual code, I would need to see the actual code you are using to see where the problem might be. –  Gonzalo Medina Sep 17 '12 at 13:57
    
I copy pasted your code and compiled it, all the text appears to be centered right, while I want text to be appear left centered –  Shashwat Sep 17 '12 at 14:06
    
@Shashwat something else must be going on in your actual code since my example as is doesn't behave like that; again, we need to see the actual code you are using. –  Gonzalo Medina Sep 17 '12 at 22:53
    
Could you please remove the image/address. I don't want to put in on internet. Thanks –  Shashwat Jun 24 at 11:59

Some general comments on the code

\newcommand{\head}[1]{\noindent \\ \\ \large \bf #1}

Try to avoid using \\ at all, and certainly for adding vertical space, this doesn't add vertical space but rather it adds blank lines (which don't stretch and which do the wrong things at page breaks) To add vertical space use \vspace{2\baselineskip} This command does not use any braces so would make any following text be large and bold. Also \bf is a deprecated command only defined in some classes (not in latex itself) for compatibility with the old latex2.09 system.

Better would be

\newcommand{\head}[1]{{\par\large \bfseries \noindent#1\par}}

You should always make sure if using size change commands that the end of the paragraph is in the scope of the size change, otherwise you get large text on a small baseline and irregular spacing.

\begin{center} {

LaTeX environments imply grouping so you don't need (and in some cases must not have) the extra `{' group around the environment contents. In this case it is mostly harmless, but it would be better to use simply

\begin{center}

Each of your environments is a full width display, aligned left right or center, so they come one below the other. You want a three column layout, so the simplest thing is to use a table.

\usepackage{array}

....

   \begin{tabular}{%
     >{\raggedright\large\bfseries}p{3cm}%
     >{\centering}p{5cm}%
     >{\raggedright\arraybackslash}p{2cm}%
     %
Contact Information&
address here .. &
Voice\\
...
\end{tabular}
share|improve this answer
    
Thanks a lot sir, will keep your tips in mind. As far as {} is concerned, its a bad habit from my C++ coding –  Shashwat Sep 17 '12 at 13:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.