Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I know this post may be related to others on MiKTeX and TeXnicCenter, I read most of those. Yet, my problem is still unsolved. Any help would be awesome!

I used to work on TeXnicCenter on another computer so some files I had are correct and pdf were accessible at that time; yet I cannot access them opening the .tex on my new system. I already went through some options to solve this issue.

  • for MiKTeX "install packages on the fly", I have chosen "ask me first"; and change the package repository in Maintenance (admin) for MiKTeX .

  • I followed all steps in configuring the output profiles in TeXnicCenter (see this link http://www.statslab.cam.ac.uk/~eva/texniccenter.html), and my path directory to adobe is: C:\Program Files (x86)\Adobe\Reader 8.0\Reader\AcroRd32.exe (I didn't take Adobe reader X since some web sites don't recommend it) the path directory for pdf is: C:\Program Files\MiKTeX 2.9\miktex\bin\x64\pdflatex.exe (notice that I have x64, could that be a problem?)

  • I tried to open a very simple draft on MiKTeX (TeXworks) and it all the aux, log, and the pdf were produced.

  • yet, I opened this same file (erasing the aux, log, out in my folder) with TeXnicCenter, no out/pdf files are produced.

  • each time, I procede to build the pdf, the adobe window opens but stays empty. No .out, .aux files are produced, only the .txt. Error message: there was an error opening this document. The file cannot be found.

share|improve this question
3  
IIRC you have to choose either Yes or No (but not "Ask me first") for the option "Install missing packages on-the-fly" in order to work correctly with TexnicCenter. –  hakaze Sep 18 '12 at 13:37
    
@Speravir I use the Texnic Center version 1.0 stable RC1. As recommended in the link given www.statlab.cam.ac.uk, I set the command line argument; there was no need to precise the DDE server. (what I haven't done yet is to add the three Tex to Pdf, PS and DVI as Eva recommends in this same link. This should be independant of my problem) –  saradi Sep 19 '12 at 6:51
    
@hakaze, Yes I eventually change it. –  saradi Sep 19 '12 at 6:52
    
@Kurt, how can I access those configuration informations you need? Further remark, "beyond adobe reader" window immediately opens when adobe reader does. –  saradi Sep 19 '12 at 6:53
    
@saradi: have a look on the question texniccenter-adobe-acrobat-10. There are the configuration informations for reader X shown. You can upload screenshots by edditing your question (see image upload). –  Kurt Sep 19 '12 at 13:17
add comment

1 Answer 1

No feedback for about a month, but let’s generally summarize some possible issues, partly already mentioned in the comments:

  • The Adobe Acrobat/Reader must be closed before recompiling the source.

  • The security feature called Protected Mode of Adobe Reader must unfortunately be set off (!) for proper working, see answer of alex.jordan and answer of innrain to TeXnicCenter & Adobe Acrobat 10.

  • If you use Adobe Acrobat or Reader X and opted for DDE, you need to change the DDE server name, see Big Changes in the DDE Naming Convention for Acrobat X, note that X is major version 10. According to this blog entry for every new version the server name must be changed again, for the very recently published version XI respectively the major version is 11.

  • Since MiKTeX 2.9 (and also since TeX Live 2010) for MakeIndex and BibTeX no absolute paths are allowed anymore (probably this is also true for biber, but I didn’t try). Unfortunately TeXnicCenter’s presettings use the variable %bm, which will be replaced by the base of the current project’s main file including the absolute directory path followed by the file name without the file extension. You must change %bm to %tm, which stands for the file name base without the path.

  • TeXnicCenter 1.0 RC1 does not work together with MiKTex’s option for package installation on-the-fly named “Ask me first”. You must change it to “Yes” or you make a full MiKTeX installation (what shouldn’t be a problem with today’s sizes and prizes of hard drives). As a sidenote this bug is fixed in TeXnicCenter 2.0.

share|improve this answer
    
+1! You seem to know your way around TXC and partners, do you think you could tackle the task described in meta.tex.stackexchange.com/questions/2389/… ? –  doncherry Oct 14 '12 at 22:35
    
Oh, thanks for the hint. I totally overlooked this. I must take a deeper look first, but it seems to me the same problem behind. Perhaps I wrote the canonical answer some minutes ago above our comments? ;-) –  Speravir Oct 14 '12 at 22:51
    
Your answer has definitely taken some steps towards the canonical answer, you could take it from there. I kinda envision an answer with a bunch of the most commonly appearing problems and their solutions. Plus perhaps a few tweaks here and there (e.g. suggesting a switch to Sumatra PDF, but also providing the answers for Adobe Reader). –  doncherry Oct 14 '12 at 23:04
    
Ah, yes I didn’t think of it. –  Speravir Oct 14 '12 at 23:20
    
Thanks for those further advices. I might have to use the MakeIndex and BibTex later on; and will see if %tm can efficiently replace %bm. I eventually solved the pdf production problem by working simultaneously with Texworks and TexnicCenter :) command line argument in compiler -interaction=nonstopmode "%pm" path in Viewer C:\Program Files (x86)\Adobe\Reader 10.0\Reader\AcroRd32Info.exe (if this can help others) –  saradi Oct 16 '12 at 20:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.