Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to embed MetaPost graphics inside a LaTeX file using the emp package, with pdflatex.

When I include the line:

\usepackage{emp} %part 1

pdflatex doesn't produce any output (it says 0 pages), but doesn't seem to create an error.

I've checked that it works without that line, and I've checked that emp is installed. I've tried reinstalling MiKTeX, which someone said worked on a similar problem. I haven't even included any MetaPost yet. I've tried it with the lines suggested at this page (which I've divided into part 2 and part 3:

http://www.cs.bgu.ac.il/~gwiener/software-engineering/how-to-embed-uml-in-latex/

And I've tried it without. The only way it will give output is if I don't include any of that stuff. If part 1 is there, it just doesn't work.

Am I being a complete moron?

Attached is a MWE.

\documentclass{article}

%part 1:
\usepackage{emp}

%part 2:
\ifx\pdftexversion\undefined
\usepackage[dvips]{graphicx}
\else
\usepackage[pdftex]{graphicx}
\DeclareGraphicsRule{*}{mps}{*}{}
\fi

\begin{document}
\begin{empfile} %part 3
\begin{empcmds} %part 3
input metauml;  %part 3
\end{empcmds}   %part 3
\section{What is a set?}
A set is a collection of objects.
\end{empfile}   %part 3
\end{document}
share|improve this question

closed as too localized by egreg, Paulo Cereda, Kurt, lockstep, Paul Gaborit Nov 3 '12 at 23:37

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
You have to run Metapost on the resulting .mp file and run LaTeX again; but you have no emp environment in the example. Can you add one? However, I get one page. –  egreg Sep 20 '12 at 9:48
2  
The \ifx\pdftexversion\undefined in your example is wrong in a modern system. \pdftexversion is always defined, even if you run latex. Use the ifpdf package for such tests. –  Ulrike Fischer Sep 20 '12 at 10:44
    
Following @UlrikeFischer's remark: Your whole section with \ifx\pdftexversion\undefined is not needed: Just load graphicx without an explicit driver and it will pick the right one. –  Martin Schröder Sep 21 '12 at 9:02
add comment