Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I can see that MiKTeX 2.9 (of which I use the "Portable" version) has an executable for "mft", which (if run with no arguments) will crash and print:

 Usage: mft inputfile changefile stylefile outputfile. (l.0)

I cant't find any other documentation, besides a brief one-line summary of the purpose of mft. This is the most I can get it to do:

 E:\home\tex\metafont>touch null.ch

 E:\home\tex\metafont>mft modes.mf null.ch \Tools\miktex-2.9\mft\plain.mft modes.tex
 This is MFT, Version 2.0 (MiKTeX 2.9)
 mft: Read operation failed.

Judging by the output of SysInternals' procmon tool, it looks like it must be objecting to "null.ch" being empty, but I haven't the foggiest idea why it demands such a file :-(. Any clues??

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

In general these more "exotic" (old) tools expects in miktex exactly the arguments they mention. I could run mft with the command line

mft script10.mf test.ch plain.mft script10.tex

test.ch is a text file with only a percentchar (%) as content (I minimized an existing ch-file). plain.mft I found on CTAN.

The output is a plainTeX-file. It doesn't have a \bye at the end (this is probably intended to that you can input it in another document), but apart from this one can compile it with pdftex.

share|improve this answer
    
I guess I should have tried something like that to see if it would passify MikTeX -- but no, I went and decided to assume that it would be consistant, and always complain at EOF. (That, and I wasn't familiar enough with the syntax to realize that I could put anything but whitespace inside a zero-section change file. ;-) –  SamB Feb 8 '11 at 19:26
    
I wonder if that would also pacify weave, which I've since noticed seems to suffer from something very similar... –  SamB Feb 8 '11 at 19:27
add comment

Hm, I am looking at the man page for the linux TexLive 2009 mft, and it says that the change file and the style file are optional. It also says "Specify command-line options -c to suppress the reading of a change file, and -s to suppress the reading of a style file." You can try to leave out the null.ch or replace it by -c.

share|improve this answer
    
Yeah, I looked at that too, but the MiKTeX port is unfortunately different. Perhaps it is just plain broken? –  SamB Dec 19 '10 at 22:28
    
Hmm, I wonder how much of TeX Live would be needed to use their MFT, though? –  SamB Dec 19 '10 at 22:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.