Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the titlesec package to adjust the chapter titles/headings of my text. Yet, I have trouble with the resulting distance between these new titles and the body of the text. Namely, the distance becomes substantially smaller than what it is when no adjustment is made, i.e., chapter titles are the default ones.

I have noted that this decreament of the distance, probably has to do with the text body moving "upwards".

Here is what I have compiled:

\documentclass[12pt, twoside, a4paper]{book}
\usepackage{graphics}
\usepackage[dvips]{graphicx}
\usepackage{fancyhdr}
\usepackage[namelimits]{amsmath}
\usepackage[mathcal]{euscript}
\usepackage{blindtext}
\usepackage{amsmath}
\usepackage[textheight=630pt]{geometry}
\topmargin -0.1in
\setlength{\headheight}{14.71pt}
\parskip=3pt
\addtolength{\parindent}{2pt}
\usepackage{titlesec}

\titleformat{\chapter}[display]
       {\bfseries\Large}
       {\filright\MakeUppercase{\chaptertitlename} \Huge\thechapter}
       {.5ex}
       {\titlerule[.1ex]\filleft}


\begin{document}
\chapter*{Introduction}
     \blindtext[3]
     \blinddocument
\end{document}

Any ideas of how to restore this distance back to the default? The titlesec documentation is not of great help (to me at least) on this issue.

share|improve this question
    
Look for the \titlespacing command in titlesec. A tip: don't load graphics and remove the dvips option from graphicx. –  egreg Sep 24 '12 at 12:55
    
The answer to your question can be found in section 9.2. of the titlesec manual. –  lockstep Sep 24 '12 at 13:00
    
As well, once you load geometry, why don't use all its options to specify the page dimensions? Like \usepackage[textheight=630pt, headheight=14.71pt, tmargin=0.9in, includehead]{geometry} (And please take my and @egreg's comments as friendly advices, we're just wanting to make your LaTeX life a bit easier ;) ) –  yo' Sep 24 '12 at 13:09
    
Thanks for your comments, I did incorporate them. Also, I hadn't seen this version of the titlesec manual which, on 9.2 gives the commands for the standard classes. Yet, it does not seem to solve the problem, unless I am just doing something silly. I added to my code the line \titlespacing*{\chapter} {0pt}{50pt}{40pt} (since it seems the only relevant; Ihave not adjusted sections, subsections etc.) but the problem persists. –  lontvag Sep 24 '12 at 13:18
    
If you do \titlespacing*{\chapter}{0pt}{80pt}{50pt}, is it better? –  yo' Sep 24 '12 at 13:33

1 Answer 1

up vote 1 down vote accepted

You have to use

\titlespacing*{\chapter}{0pt}{80pt}{50pt}

and modify the values as you wish.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.