Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I need to introduce one Hebrew word in a document. I have been trying to add an hebrew option in my Babel includepackage command, as in the following code, but it does not work: it triggers a clash with almost all the other packages (in the following examples, all the ones below inputenc).

\documentclass[10pt]{article}
\usepackage[english,hebrew,french]{babel}
\usepackage{aeguill}
\usepackage[utf8x]{inputenc}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{xspace}
\usepackage{listingsutf8}
\usepackage{color}
\usepackage{url}
\usepackage{textcomp}

\begin{document}
Blah
\end{document}

This is a minimal non-working example: I need all these packages for my document. How can I display Hebrew text here? I'd like to avoid including it as a picture...

share|improve this question
    
I'm using sometimes Arabic script, I was adviced to use XeLaTeX instead of LaTeX, and polyglossia package instead of babel. You can check my question about Arabic here: [tex.stackexchange.com/questions/12347/… –  maria Sep 25 '12 at 14:12
    
Thanks, but I'm not going to change both my software and one of my most common packages just to display one word... Your suggestion might be helpful to other people though. –  Eusebius Sep 25 '12 at 14:15
    
Load inputenc before babel. One of the bad habits of hebrew.ldf is that it loads inputenc if you haven't done it already. –  Ulrike Fischer Sep 25 '12 at 14:15
    
As you want, but you don't need to install any new software. You just change the preamble. For me XeLaTeX works better for multilanguage documents. –  maria Sep 25 '12 at 14:18
    
@maria xelatex is not the software I use, so yes, it would mean switching software. –  Eusebius Sep 25 '12 at 14:21

1 Answer 1

Pobably this is not a package conflict, but rather the lack of babel support for Hebrew. A possible solution (not tested) is to install the package IvriTeX (Hebrew package for the babel system and LaTeX2e). To install in a Debian system:

apt-get install ivritex

In other case go to http://ivritex.sourceforge.net/

Another solution is to remove hebrew from the babel options and use the cjhebrew package:

\documentclass[10pt]{article}
\usepackage[english,french]{babel}
\usepackage{aeguill}
\usepackage[utf8x]{inputenc}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{xspace}
\usepackage{listingsutf8}
\usepackage{color}
\usepackage{url}
\usepackage{textcomp}
\usepackage{cjhebrew}

\begin{document}
\begin{cjhebrew}
b*:re’+siyt b*ArA’ ’E:lohiym ’et ha+s*Amayim w:’et hA’ArE.s; w:hA’ArE.s
hAy:tAh tohU wAbohU w:.ho+sEk: ‘al--p*:ney t:hOm
\end{cjhebrew}

L'e'quation $E=mc^2$ a e'te' exprime'e en 1905 par Albert Einstein.
\end{document}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.