Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like the author names in the bibliography to be of the form "Lastname, A.B."

I thought that it is the bibliography style file like APA or Chicago which will choose only the initials of the author's first name and ignore the full name that has been typed (e.g. Andrew Middlename Lastname). All the styles tried so far do not compress the information typed in author field. Does that mean I have to enter the names in the required format only or is there some Tex solution to it?

Edit: In view of the tags apa and chicago added by the moderators, my guess is that the answer can be adapted to them by using \usepackage[style=authoryear,natbib=true,uniquename=init,firstinits,bibstyle=chicago]{biblatex} and installing biblatex-chicago.bst file? or is there another way?

Update: In response to the answers, I would have posted this before but didn't know exactly how to do that.

\documentclass{article}
\usepackage{filecontents}
\\
\begin{filecontents*}{demo.bib}
@book{test,
  author = {Herbert Voss},
  title  = {Me, I and myself},
  year   = 2010,
  location = {Berlin}}


@ARTICLE{Name10,
  author = {{F}irstname {M}iddlename {L}astname},
  title = {{T}itle of the paper},
  journal = {{J}ournal {T}itle },
  year = {2010},
   }

\end{filecontents*}
\\
\usepackage[style=authoryear,natbib=true,uniquename=init,firstinits]{biblatex}
\bibliography{demo}

\begin{document}
A reference to~\cite{test}.

\cite{Name10}

\printbibliography
\end{document}
share|improve this question
    
If you want to mark a code sample, highlight it an hit the button for "code sample". This is the button with "101010" on it. –  Hendrik Vogt Dec 21 '10 at 12:20
    
I did that but doesnt seem to make a difference! –  Anusha Dec 21 '10 at 12:23
    
Were you able to remove the braces from the author names? –  Torbjørn T. Dec 22 '10 at 11:48
    
@Torbjorn: Yes, by the method suggested. Thanks. –  Anusha Dec 23 '10 at 9:01

3 Answers 3

up vote 12 down vote accepted

if you can use the package biblatex, it is easy:

\documentclass{article}
\usepackage{filecontents}
\begin{filecontents*}{demo.bib}
@book{test,
  author = {Herbert Voss},
  title  = {Me, I and myself},
  year   = 2010,
  location = {Berlin},
  url    = {http://www.myirl.org},
  urldate= {2010-03-04},
} 
\end{filecontents*}

\usepackage[style=authoryear,firstinits,url=false]{biblatex}

\bibliography{demo}

\begin{document}
A reference to~\cite{test}.

\printbibliography
\end{document} 

alt text

share|improve this answer
    
Thanks Herbert. Your example file is running but I had to load package "csquotes" and specify [uniquename=inits] eg. \usepackage[uniquename=inits,style=authoryear,firstinits]{biblatex} as shown in the error log to get the result on my bib file but the format is not as desired. Also, it is showing all the urls and optional information which I donot want in the bibliography. –  Anusha Dec 19 '10 at 17:50
    
\usepackage[style=authoryear,firstinits,url=false]{biblatex} –  Herbert Dec 19 '10 at 18:52
    
I don't know why but still not getting the Lastname, A.B. format with this method on my .bib file. –  Anusha Dec 19 '10 at 21:01
    
I figured it out. Its because the author names are not entered as Lastname, firstnames. Any trick for modifying the data entries? –  Anusha Dec 19 '10 at 22:08
    
Did you have a text editor that supports Regular Expression find/replaces? –  frabjous Dec 19 '10 at 23:17

Edit

The problem with the example you just added, is that you have curly brackets around the first letters of the names. Remove those, and you get "Lastname, F. M.". That is, your author field should be

author = {Firstname Middlename Lastname}


Biblatex is, I gather, "the way to go", but if you want to use e.g natbib, you can try the agsm style, which is from the Harvard family of bibliography styles.

Adapting the example given by Herbert (I didn't know about the filecontentspackage, thanks):

\documentclass{article}
\usepackage{filecontents}
\begin{filecontents*}{demo.bib}
@book{test,
  author = {Herbert Voss},
  title  = {Me, I and myself},
  year   = 2010,
  location = {Berlin}} 
\end{filecontents*}

\usepackage{natbib}


\begin{document}
A reference to~\cite{test}.

\bibliographystyle{agsm}
\bibliography{demo}
\end{document}

Which gives as output

alt text

share|improve this answer
    
Thanks. Since I use Jabref for entering the info, it capitalizes what is typed in capitals. Is there a way to remove the braces automatically from the author fields only, as I would like them in the Title field? Also, is there a way to remove the "In:" which accompanies all the articles bibliography format? –  Anusha Dec 21 '10 at 12:39
    
You can try using Tools --> Replace String in JabRef. First, search for {, replace with nothing (leave that empty), and limit the search to the author field. Repeat for }. That seemed to do the trick for me. As for your other question, I don't know. –  Torbjørn T. Dec 21 '10 at 13:17

Consider making your own .bst file by running:

latex makebst

from the command line. You'll get an option to choose the full first name or just the initials.

share|improve this answer
    
and tons of other options which must be answered ... ;-) –  Herbert Dec 20 '10 at 8:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.