Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I face problems while using Gyre with MiKTeX.

The simple example is a template for a journal, downloadable at http://nlp.ipipan.waw.pl/ojs/public/jlm-latex.zip

Following the README file, I installed the packages tex-gyre, qtx and qpx. I have a problem with the simple example file, characters in math mode are not rendered.

Here is the ME:

\documentclass{article}
\RequirePackage{qpxmath}

\begin{document}
$x$
\end{document}

actually, the problem is not with the gyre font installation as I first thought, nor with tgpagella package, but with qpxmath package. qpxmath in in TeXLive in texlive-lang-polish, but it's quite hard to find for MiKTeX, I'm looking for it right now and I'll post a link here as soon as I find it.

share|improve this question
2  
Make a minimal example that demonstrates the problem. –  Ulrike Fischer Sep 27 '12 at 18:02
    
In addition to Ulrike: I've just been told I have to write a minimal example, what is that?. –  Speravir Sep 27 '12 at 21:18
    
thanks, I edited my question, and provided an explanation how to simply reproduce the problem –  Maxime Lefrançois Sep 28 '12 at 8:52
1  
@MaximeLefrançois There is no qplri.tfm file in the distribution. We need an example of LaTeX code that produces the error, not just the .log –  egreg Sep 28 '12 at 13:26
    
That was not what was mentioned by Ulrike or Speravir. A complete MWE shows us in short form (all packages and code not related to the problem is deleted!) what you have tried. For example users don't mention that they used documentclass xy, in the MWE we can see it and so on. Take the time to build your own MWE, it also helps you to find the error. –  Kurt Sep 28 '12 at 13:29
show 5 more comments

1 Answer

up vote 2 down vote accepted

It seems, that you have a basic MiKTeX installation: Your MWE works for me with a full installation. Go into the Package Manager and install the package qpx. Note, that in the MiKTeX Settings in the General tab there is a setting for Package installation. If I remember correctly the default setting here for “Install missing packages on-the-fly" is “Ask me first”. You could set it to “Yes” and it will do installations without any asking. The compilation time would once be remarkable longer, of course.

Perhaps you also face some confusion concerning administrative and user mode, see Difference between administrative and user mode of MiKTeX.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.