Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I can't seem to make my math come out in bold using the mathspec package. Consider this example:

\documentclass{article}

\usepackage{mathspec}
\setallmainfonts{Times New Roman}

\begin{document}

\textbf{This line should all be bold: {\boldmath $17^2 = 289$}.}

\end{document}

When compiled, it gives:

bm

If mathspec is not used, then the math is bold, like it should be. How can I make my custom-font math bold as well?

share|improve this question
1  
Possibly related to tex.stackexchange.com/questions/603/math-in-trebuchet-ms. –  Ben Alpert Jul 31 '10 at 20:54
1  
Maybe some clever usage of \setboldmathrm command (from fontspec package) can solve this problem (but I failed). –  Grigory M Aug 1 '10 at 19:23
    
At least it's possible to get bold math: \setmathsfont(Digits,Latin,Greek){Times New Roman Bold} Though all math would be bold then. –  Stefan Kottwitz Aug 15 '10 at 19:02
add comment

1 Answer

up vote 6 down vote accepted
+50

Separating out the font setting for math and text seems to work

\documentclass{article}
\usepackage{mathspec}
\setmainfont{Times New Roman}
\setmathfont{Times New Roman}

\begin{document}

\textbf{This line should all be bold: {\boldmath $17^2 = 289$}.}

\textbf{This line should all be bold except the
math: {$17^2 = 289$}.}

\end{document}
share|improve this answer
    
Indeed it does. Thanks! –  Ben Alpert Aug 16 '10 at 6:18
    
Very good idea! –  Stefan Kottwitz Aug 16 '10 at 20:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.