Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have some trouble with margins in multi-column layout beamer slides. If put the following snippet in a non-rounded theme like "Rochester", you will see that

  1. the boxes of the first row have different margins than the boxes of the 2nd row (the 1st row has an "indent", which also affects the position of the central line between the boxes)
  2. the rightmost margin differs from the leftmost margin (the left margin is smaller than the right one, which optically goes away when one uses shadows)

any ideas?

\begin{frame}[t]
\frametitle{...}
\begin{columns}[T]
  \column{.50\textwidth}
  \begin{block}{...}
     ...
  \end{block}
  \column{.50\textwidth}
    ...
\end{columns}
\vspace{3mm}
\begin{columns}[T]
  \column{.50\textwidth}
  \begin{block}{...}
    ...
  \end{block}
  \column{.50\textwidth}
  \begin{block}{...}
    ...
  \end{block}
  \end{columns}
\end{frame}
share|improve this question

1 Answer 1

up vote 5 down vote accepted

How should this work when you define two columns each with a width of 0.5\textwidth. You have to add the columnsep and all together is > \textwidth, the reason why beamer shifts all to the left.

\documentclass{beamer}
\usetheme{Rochester}

\begin{document}

\begin{frame}[t]
\frametitle{...}
\begin{columns}[T]
  \column{.425\textwidth}
  \begin{block}{...}
     ...
  \end{block}
  \column{.425\textwidth}
    ...
\end{columns}

\noindent
\rule{\textwidth}{5pt}

\begin{columns}[T]
  \column{.425\textwidth}
  \begin{block}{...}
    ...
  \end{block}
  \column{.425\textwidth}
  \begin{block}{...}
    ...
  \end{block}
  \end{columns}
\end{frame}

\end{document} 

Look into the documentation for the value of the columnsep; then you can define it exactly to \textwidth.

share|improve this answer
    
@Herbert: I marked your inline code with backticks. –  Hendrik Vogt Dec 20 '10 at 14:20
1  
thanks! I tried setting \setlength\columnsep{0pt}, but that does not affect the beamer output. Indeed, the beamer manual does not mention columnsep at all! –  hannes Dec 20 '10 at 15:29
1  
it is hardcoded as \end{minipage}\hfill\begin{minipage} ... not a good idea by beamer –  Herbert Dec 20 '10 at 16:26
    
@Herbert, does that mean I can't do a thing about it? –  hannes Dec 21 '10 at 0:57
4  
@Herbert, can we express the column width exactly in terms of \textwidth, \columnsep or other related length commands rather than using the "magic" number 0.425? –  xport Dec 23 '10 at 12:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.