Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I make an index, or two, and print them at the end of a document, they show up in columns, just I would like. However, when adding further sections after the printed index, they continue formatting under the two-column format. How can I reset the margins and layot settings to normal?

share|improve this question
    
\onecolumn after the index? –  David Carlisle Sep 27 '12 at 23:36
    
How do you get the index? What package are you using for multiple indices? –  egreg Sep 28 '12 at 7:48
    
you might try adding \begingroup before the first index and \endgroup after the second. (the fact that the original page format isn't restored after an index sounds like a design flaw to me.) –  barbara beeton Sep 28 '12 at 12:33

1 Answer 1

You can use the idxlayout or imakeidx packages, that modify the definition of the index related macros so that the problem of restarting to write in one column is overcome.

The imakeidx package also supports more than one index; its automatic feature should be disabled, though, if the further section after the indices add material to them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.