Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I create a .bib file

@article {HanKumar2011,
author = {Han, Bing and Kumar, Alok},
title = {Speculative Retail Trading and Asset Prices},
journal = {Journal of Financial and Quantitative Analysis (JFQA)},
volume = {Forthcoming},
year = {2011},
}

I then import this file into by .lyx file by doing insert > list/toc > bibtex bibliography. I select the database as the file I have created. The style I select as plainnat. I then go to cite the paper via insert > citation, add the particular id, the preview of the actual cite seems to show up fine. However the problem is that the only citation style available is [#ID] under formatting. I need one that allows me to do author (yyyy). I can't seem to fix this. Does anyone know what's going on?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Seems you have to activate this in the settings, so go to Document --> Settings --> Bibliography, and choose Natbib and author-year as citation style. Then you'll have more styles to choose from.

enter image description here

share|improve this answer
    
Is there an example list of styles available, so I can predict what will be generated? –  johntait.org Jun 18 '13 at 11:57
    
Note -- it doesn't seem sufficient to change the citation style of your master document. I had to also change it for each child document before the natbib options appeared in the citation dialogue. –  Desty Jun 8 at 17:24
    
I have changed this in my document and changed each citation style to (Surname, year). The LyX preview shows the citation style I want. However, the resulting PDF remains in the numeric [1] style. (LyX 2.1 on Windows) –  badp Jul 29 at 14:49
    
@badp Which bibliography style are you using? Works fine here with plainnat. –  Torbjørn T. Jul 29 at 19:16
    
@TorbjørnT. Ooooh, good catch! You also have to set your bibliography section to use plainnat instead of plain. –  badp Jul 29 at 19:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.