Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to add a pair of lines in Russian to some file, which I'm writing with classicthesis. I tried adding cyrillic alphabet with the packages described just bellow, and had still no problem:

\documentclass{article}
\usepackage[T2A,T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[russian,english]{babel}

\begin{document}

English text and 
\begin{otherlanguage*}{russian}
русский текст
\end{otherlanguage*}

\end{document}

But when I add the lines that allow me to write in cyrillic to a working example written with classicthesis, I get Option clash for package inputenc.\usepackage and Option clash for package babel upon compiling the following:

\documentclass[ twoside,openright,titlepage,numbers=noenddot,headinclude,%1headlines,% letterpaper a4paper
                footinclude=true,cleardoublepage=empty,abstractoff, % <--- obsolete, remove (todo)
                BCOR=5mm,paper=a4,fontsize=11pt,
                ngerman,american,
                ]{scrreprt}

\usepackage{classicthesis-preamble} 
\usepackage[T2A,T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[russian,english]{babel}

\begin{document}
\frenchspacing
\raggedbottom
\selectlanguage{american} 

English text and 
\begin{otherlanguage*}{russian}
русский текст
\end{otherlanguage*}}
\end{document}

Any hint?

share|improve this question
    
Is that bunch of options to \documentclass relevant for your problem? If not, it'd be good if you removed that to make your code more minimal. –  doncherry Sep 29 '12 at 6:35
2  
In the most recent versions of classicthesis the classicthesis-preamble package has been removed. If I load \usepackage[parts]{classicthesis} instead and move \part{...} after \ctparttext{...} (where it belongs) the document compiles. –  egreg Sep 29 '12 at 9:14
1  
@JorgeCampos: That's beside the point. The question is whether your problem, i.e. the two option clash errors persist if you don't use these options; and as far as I can see, that is the case. Hence, you should remove these options from the MWE you provide here. One of our supreme goals for questions at tex.sx is to formulate problems in a way as abstract as possible, in order to make the problems and solutions applicable to as many users as possible. In other words, your specific application for the solution to be found here is not of interest. –  doncherry Sep 30 '12 at 0:50
1  
I see. Ok, I'll make the code minimal... –  c.p. Sep 30 '12 at 0:56
1  
@JorgeCampos It's impossible to answer without knowing what you have in classicthesis-preamble. Of course, \selectlanguage{american} is wrong, as you don't specify american but english in the options to babel. –  egreg Sep 30 '12 at 8:21
show 5 more comments

1 Answer

up vote 2 down vote accepted

Assuming that classicthesis-preamble.sty is similar to the file

/usr/local/texlive/2012/texmf-dist/doc/latex/classicthesis/classicthesis-config.tex

that's included in the most recent distributions of ClassicThesis, then you have several problems.

The file calls

\PassOptionsToPackage{latin9}{inputenc} % latin9 (ISO-8859-9) = latin1+"Euro sign"
 \usepackage{inputenc}

(which is a very peculiar way to proceed, since \usepackage[latin9]{inputenc} would do the same).

and so if you use it (or classicthesis-preamble.sty that should have the same line) you can't specify another input encoding after having loaded it.

So the solution is: don't load classicthesis-preamble. Having it was a mistake since the start of the ClassicThesis project. Now the distribution proposes the file I pointed to, but it's again an error to include it "as is": it must be tailored to your needs.

The same problem happens also with babel; you might solve this one by specifying russian,english among the global options, but the safest solution is to rip off the call of babel from the auxiliary classicthesis-preamble package.

Don't use \selectlanguage{american}: the last language loaded by babel is the default one; moreover you have english in the options (which is equivalent to american but you should always use the same name throughout a document).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.