Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the memoir class with a numeric citation style that adds the letter "r" before a reference. A minimal example would be this:

\documentclass{memoir}
\usepackage[super]{natbib}
\usepackage{hyperref}

\setcitestyle{open={[r},close={]},citesep={; r}}

\begin{document}

Here is the document's body text. Dummy\citep{Erdos01,lamport94} text. Dummy text.

\begin{thebibliography}{9}
\bibitem{Erdos01} P. Erd\H os, \emph{A selection of problems and results in combinatorics}, Recent trends in combinatorics (Matrahaza, 1995), Cambridge Univ. Press, Cambridge, 2001, pp. 1--6.
\bibitem{lamport94}
  Leslie Lamport, \emph{\LaTeX: A Document Preparation System}. Addison Wesley, Massachusetts, 2nd Edition, 1994.
\end{thebibliography}

\end{document}

The superscript citation style is achieved with natbib's super option (and I'd like to maintain this setup), and the link boxes around the citation numbers are achieved through hyperref.

The reference compiles to a superscript "[r1; r2]", as intended, but hyperref's link boxes cover only the numbers "1" and "2"; how do I make hyperref's boxes cover the entire "r1" and "r2"?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Punctuation characters are not part of the link. You can try instead:

\renewcommand*{\citenumfont}[1]{r#1}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.