Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have been using the currvita.tex template located here with TeXShop. Unfortunately, the output is not 8.5" by 11". Is there some way I can change either TeXShop settings or the TeX document to adjust the page size?

share|improve this question
1  
Carsten answers your question, but note that you don't have to use scrartcl. currvita.sty works quite well with the article class. –  TH. Dec 20 '10 at 21:58
    
I've posted a similar question for the memoir class here: Customizing Page Size in Memoir –  jamaicanworm Dec 25 '11 at 6:24
add comment

3 Answers

up vote 7 down vote accepted

The template uses the KOMA documentclass scrartcl. You can switch to letter paper by replacing the first line with

\documentclass[letterpaper]{scrartcl}

You will probably have to play around with the layout as it is optimized for a4 pages.

share|improve this answer
    
You also need to pass the pagesize option, see Why does setting the paper size with KOMA-Script require TikZ? –  Caramdir Dec 20 '10 at 22:05
add comment

Carsten's suggestion is good, just to add some other possible ways of changing page parameters.

A very quick and dirty hack, just after the \begin{document} add:

  \pdfpageheight 8.5in 
  \pdfpagewidth 11in

For a different way - to get finer control use the geometry package (just change the parameters to suit)

\documentclass{scrartcl}    % classe article di KOMA
\usepackage[total={6.5in,8.75in},top=1.2in,
  left=0.9in, includefoot]{geometry}
share|improve this answer
    
the direct command didn't work. The only thing that geometry package did was to mess up with my figure without noticing any affect on the actual document size. –  Yotam Jan 10 '12 at 20:51
add comment

For changing TeXShop directly, add:

--extradvipsopts "-t letter"

to the simpdftex command in TeXShop->Preferences->Engine->TeX + dvips + distiller and then use Tex and DVI when typesetting.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.