Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have been trying for a long time now to install the MathTime Professional II (mtpro2) fonts on my system. (I am running MikTeX 2.9 under Windows 7, but what likely matters is "recent MikTeX, under Windows", which is general enough to be of interest to many people.) I've tried various things:

  1. First step:
    • Merging the "texmf" directory structure into my MikTeX root directory ("C:\Program Files\MiKTeX 2.9") or
    • registering a new root directory ("C:\Local TeX Files") and
      • putting mtpro2's "texmf" directory directly in there or
      • putting the subdirectories of mtpro2's "texmf" directory in there
  2. Second step: Running initexmf --edit-config-file updmap and adding the lines "# MathTimePro II" and "Map mtpro2.map" to the file.
  3. Third step: Running any and all of the following commands in various orders and combinations:
    • From the command prompt (always in Administrator mode (right-click -> "Run as administrator")): updmap, texhash, mktexlsr, initexmf --admin -u
    • Accessing the MikTeX "Options" dialogue (via running MikTeX 2.9 -> Settings as Administrator) and then choosing both "Refresh FNDB" and "Update Formats"

None of this seems to work. Right now the error messages I get when trying to compile the enclosed sample file "MTPro2 LaTeX test.tex" is the following:

!pdfTeX error: pdflatex.exe (file mt2exf): Font mt2exf at 2400 not found

==> Fatal error occurred, no output PDF file produced!

I have no clue what's happening. Also I hope I haven't cluttered the hash/database files with incorrect information in this process.

How do I install the MathTime Professional II fonts under MikTeX?

share|improve this question
1  
    
I installed the font package and the test compiled fine. After looking again onto your question I must say it seems here, too, that you mixed up something: Difference between administrative and user mode of MiKTeX. Run again without --admin (!): initexmf --force -u and then updmap --force. –  Speravir Oct 1 '12 at 22:03
add comment

2 Answers

up vote 5 down vote accepted

Update: See now the more general tutorial Manual font installation.


I did the following and it worked for me. Some steps may not be necessary or have been done redundantly. I believe I did everything in "user" mode.

  1. Created C:\Local TeX Files
  2. Put zipped fonts distribution in temporary directory and unzipped there
  3. C:\Program Files (x86)\MiKTeX 2.9\miktex\bin opened there mo.exe. changed default format to letter and added to roots C:\Local TeX Files. needed to do show MiKTeX maintained root directories so it is in the right priority among directories. System said it needed to rebuild format files and did so.
  4. Move the contents of the texmf folder to your own root directory (C:\Local TeX Files)
  5. From a command line run

    initexmf --edit-config-file updmap
    
  6. Empty file opened in notepad

  7. Add the following two lines to the file
    • # MathTimePro II
    • Map mtpro2.map
  8. Save and exit
  9. Do not change cmd directory. From a command line run (this took a long time)

    updmap
    
  10. refresh FNDB (user). update formats

  11. do the following two commands on two different lines from command line
    • initexmf --mkmaps
    • updmap
  12. refresh FNDB (user). update formats
share|improve this answer
    
I followed your instructions (with minor differences in path names on my computer/setup), and things worked! Good job. For me, I'm sure that I had previously done basically all of these (as user or admin) except the line initexmf --mkmaps. –  Lover of Structure Oct 2 '12 at 7:15
add comment

The problem I've found is that the installation puts updmap.cfg in the wrong directory. Here are my notes (which do work, eventually).

General strategy for getting mtpro fonts to work.

Run updmap --verbose from a dos box.

Run initexmf --edit-config-file updmap from a dos box.

Make sure Document and Settings/All Users/Application Data/Miktex/2.9/miktex/config contains the file updmap.cfg with the correct contents.

Note: the installation puts it in myname/Application Data/MiKTeX/2.9/miktex/config/

Put in All Users. This seems to have done the trick.

share|improve this answer
    
It seems you mixed up administrative and user mode installation, cf. Difference between administrative and user mode of MiKTeX. –  Speravir Sep 30 '12 at 23:47
    
@Speravir Not my mix up --- I installed it for all users, but then initexmf assumed otherwise. Until I moved the file, I got the same error as OP. –  anon Oct 1 '12 at 0:31
    
No: You didn’t add the option --admin, so you were in user mode. –  Speravir Oct 1 '12 at 22:14
    
@Speravir I'm upvoting this because it draws attention to what on my setup seems to have to do with so-called "shadow copies" that Windows makes in the mysterious and hidden "C:\Users\<username>\AppData" directory. I know that this may be covered by Speravir's links, so anyone feel free to add info or edit things to clarify my understanding. –  Lover of Structure Oct 2 '12 at 7:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.