Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am making a presentation in beamer. I wanted to make a TikZ picture and change it's opacity, locally on specific items. When I did, the structure color changed...

I will attach my preable as well as the frame that does the damage...

\documentclass[slidestop,compress,11pt,xcolor=dvipsnames]{beamer}
\usefonttheme[onlymath]{serif}
\definecolor{LHCblue}{RGB}{4, 114, 255}
\usecolortheme[named=LHCblue]{structure}
\usepackage[bars]{beamerthemetree} % Beamer theme v 2.2
\usepackage{kerkis}
\mode<presentation>
\newcommand*\oldmacro{}%
\let\oldmacro\insertshorttitle%
\renewcommand*\insertshorttitle{%
  \oldmacro\hfill%
  \insertframenumber\,}%/\,\inserttotalframenumber
\setbeamertemplate{footline}[frame number]
%~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
\setbeamercovered{higly dynamic}
\usetheme[watermark=ntua-logo.jpg]{Ilmenau} % Beamer theme v 3.0
\useoutertheme[subsection=true]{smoothbars}%Beamer Outer Theme-circles on top

\useinnertheme{circles} %rectangle bullet points instead of circle ones
\usepackage{beamerthemebars}
\setbeamercolor{navigation symbols dimmed}{fg=red!80!black}
\setbeamercolor{navigation symbols}{fg=red!80!black}
%~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
\title[SRS/APV readout with mmDAQ/Recomm\hspace{1.5cm} Stony Brook, NYC]{rd51 mm     tracker \& SRS/APV readout using mmDAQ/Recomm}
\author[Stamatopoulos N. Athanasios\hspace{2.5cm}{athanasios.stamatopoulos@cern.ch}]    {Stamatopoulos N. Athanasios}
\institute{NTUA/CERN}
\logo{%
  \makebox[0.99\paperwidth]{%
    \includegraphics[width=1cm,keepaspectratio]{cern_logo_white.jpg}%
    \hfill%
    \includegraphics[width=1cm,keepaspectratio]{ntua-logo.jpg}%
  }%
}
%~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
\usepackage{tikz}
\usepackage{multicol}
\usepackage{lmodern}
\usepackage{lipsum}
%\usepackage{graphicx}
\usepackage{marvosym}
%------------------tikz------------------------

\usetikzlibrary{%
calc,%
fadings,%
shadings%
}

\usetikzlibrary{arrows,snakes,shapes}

\begin{document}

\begin{frame}
\titlepage
\end{frame}

\begin{frame}
\transdissolve
\begin{columns}
\begin{column}{.48\textwidth}
\begin{tikzpicture}[scale=0.6]
\draw[->,color=red,thick](4,0) -- (-4,0);
\draw[yellow!60,fill,rounded corners,opacity=0.9] (3.5,2) rectangle (2.5,-2);%When applying opacity tha whole structure color is changed
\draw[yellow!60,fill,rounded corners,opacity=0.9] (2,2) rectangle (1,-2);
\draw[yellow!60,fill,rounded corners,opacity=0.9] (0.5,2) rectangle (-0.5,-2);
\draw[yellow!60,fill,rounded corners,opacity=0.9] (-1,2) rectangle (-2,-2);
\draw[yellow!60,fill,rounded corners,opacity=0.9] (-2.5,2) rectangle (-3.5,-2);

\draw[color=red] node at (5,0.5) {\footnotesize Beam};
\draw node at (3,-2.5) {\footnotesize mm2};
\draw node at (1.5,-2.5) {\footnotesize mm3};
\draw node at (0,-2.5) {\footnotesize mm4};
\draw node at (0,-3) {\footnotesize mm7};
\draw node at (-1.5,-2.5) {\footnotesize mm5};
\draw node at (-3,-2.5) {\footnotesize mm6};

\end{tikzpicture}\\
\hspace{1cm}
\end{column}%

\begin{column}{.48\textwidth}
\end{column}%
\end{columns}

\end{frame}
\end{document}

I changed a bit the code(again) so as to be a really MWE

Before opacity

After opacity

Can you see the difference now?

When I apply opacity in the tikz picture the whole structure color changes! Before opacity it is alive and then it goes too pale...

Any ideas on how to fix this?

share|improve this question

closed as too localized by Loop Space, Claudio Fiandrino, egreg, doncherry, percusse Oct 1 '12 at 18:40

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
Could you please cut down your code a little bit, it is hardly minimal! When I compile it, as well as missing various pictures, I have no idea what the problem is: it bears no relation to the sample images that you have posted, and even in those them I'm not all that clear what aspect has changed. Please try to find a smaller example that demonstrates the problem, that'll make it easier to find an answer. –  Loop Space Oct 1 '12 at 9:20
    
Still not minimal. There's still the \includegraphics commands - are they necessary? If so, you'll have to provide the files. And, no, I can't see the difference. Which bit of the picture am I meant to be looking at? –  Loop Space Oct 1 '12 at 10:34
1  
I've just tried your code again (you'd commented out \begin{document} by the way!) and I still don't see what I'm meant to be looking at. Could you please edit it, removing (not just commenting) all the unnecessary stuff, and mark what bit is causing the problem. A good thing to do (if possible) is put a comment before a particular line saying "Works without the next line" because then it is clear to someone trying what specifically to look for. –  Loop Space Oct 1 '12 at 10:47
    
It is now edited!I hope it is better now! Sorry for any confusion...! –  Thanos Oct 1 '12 at 13:12
    
Still rather large! Anyway, when I compile the document then I get no change in the title page. I tried putting \end{document} right after the title frame to cut off all the tikz stuff and there was no difference in the title page before and after. I'm beginning to suspect it might be due to your PDF viewer, or an old package of beamer. Try reducing your example even more. What do you need to add to \documentclass{beamer}\usepackage{tikz}\begin{document}\begin{frame}\tikz\draw[‌​opacity=.5] (0,0) -- (1,0);\end{frame}\end{document} to reproduce the problem? –  Loop Space Oct 1 '12 at 13:18

1 Answer 1

I see no change (with both Acrobat X and SumatraPDF) before and after I remove all the unnecessary code that might be interfering.

\documentclass{beamer}
\usepackage{mwe,tikz,lmodern}
\definecolor{LHCblue}{RGB}{4, 114, 255}
\usecolortheme[named=LHCblue]{structure}
\usepackage[bars]{beamerthemetree} % Beamer theme v 2.2
\usetikzlibrary{decorations.pathmorphing} %<- Instead of snakes library which is obsolete

\title[My short title although it looks longer \hspace{1cm} than my long title]{My longer and longer title}
\author[My name\hspace{2.5cm}{my@email.com}]{My name}
\institute{NTUA/CERN}
\logo{%
  \makebox[0.99\paperwidth]{%
    \includegraphics[width=1cm,keepaspectratio]{example-image-a}%
    \hfill%
    \includegraphics[width=1cm,keepaspectratio]{example-image-b}%
  }%
}
\begin{document}
\begin{frame}
\titlepage
\end{frame}
\begin{frame}
\begin{columns}
    \begin{column}{.48\textwidth}
        \begin{tikzpicture}[scale=0.6]
        \draw[->,color=red,thick](0,0) -- (-4,0);
        \draw[yellow!60,fill,rounded corners,opacity=0.9] (-1,2) rectangle (-2,-2);
        \end{tikzpicture}
    \end{column}%
    \begin{column}{.48\textwidth}
    \end{column}%
\end{columns}
\end{frame}
\end{document}
share|improve this answer
    
I guess I should register that I'm using xpdf on Mac OS X (Lion) with TeXLive 2012 and I see no difference. –  Loop Space Oct 1 '12 at 13:29
    
Really? But you see it for yourself... The color is not the same. Before using opacity color is alive... –  Thanos Oct 1 '12 at 13:57
    
@Thanos I think (but not sure) your PDF viewer cannot handle transparencies and other recent additions on the PDF specifications. Does it happen also with article documentclass instead of beamer? –  percusse Oct 1 '12 at 13:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.