Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have used hangparas from the hanging package, tried setting bibhang, setting parskip and leftindent to no avail. I have an author-year citation format and plainnat.bst and savetrees package if this matters...

Most help I find on this topic suggests use of biblatex but as I have not yet made the switch. I still find bibtex's multiple bibliography style option very useful so would like to stay with bibtex for now.

Edit: For example, I was hoping this would help, but it does nothing for the bibliography:

\begin{hangparas}{.25in}{1}
\bibliographystyle{plainnat}
\bibliography{references}
\end{hangparas}

I also tried

\setlength\parskip{\baselineskip}
\leftskip 0.1in
\parindent -0.1in
\bibliographystyle{plainnat}
\bibliography{references}

and

\setlength\bibhang{2em}
\bibliographystyle{plainnat}
\bibliography{references}

But there is no hanging indentation to be seen.

share|improve this question
2  
BibTeX has nothing to do with this, but the class and packages you're using do. So a minimal working example (MWE) is needed. –  egreg Oct 1 '12 at 10:15
1  
Do you use a citation management package such as natbib or harvard? Please advise. –  Mico Oct 1 '12 at 12:10
    
Yes, I use natbib and I've edited my question to say it's the bibliography that I want to indent. –  crippledlambda Oct 1 '12 at 16:09
1  
It would be really nice if you provided a MWE as suggested by @egreg. I think that after asking 16 questions you would understand that this makes the question much better and the answering much easier... –  tohecz Oct 1 '12 at 16:38
1  
@crippledlambda No, that's not an example. An example starts with \documentclass and ends with \end{document}; a couple of bibliography items from your .bib file are also needed. –  egreg Oct 1 '12 at 17:11

1 Answer 1

up vote 3 down vote accepted

If you had posted a complete minimal example, you probably would've had a solution many hours ago. And, needless to say, if this solution doesn't work for you, you really need to post a similar example of your own that demonstrates the problem.

At any rate, this works for me:

\documentclass[12pt]{article}

\usepackage{filecontents}
\begin{filecontents*}{example.bib}
@book{smith2000,
  author =    {Smith, John},
  title =     {A Really, Really, Really Long Book Title So the Whole Entry Is More than One Line Long},
  address =   {City},
  publisher = {Some Publisher},
  year =      2000
}
\end{filecontents*}

\usepackage{natbib}
% \usepackage[normalbib]{savetrees}% older versions
\usepackage[bibliography=normal]{savetrees}% version 2.0 (2011/05/14)
\usepackage{lipsum}

\begin{document}

\cite{smith2000}
\lipsum[1]

\bibliographystyle{plainnat}
\bibliography{example}

\end{document}

In other words, savetrees allows you to set various options that determine how many trees you're going to save. In this case, the bibliography=normal option prevents savetrees from modifying the bibliography formatting.

share|improve this answer
    
Hey thanks, running a tight deadline so haven't gotten a chance to put together an example but filecontents is convenient - didn't know. Also, apparently normalbib option is deprecated in favor of bibliography=normal (mirror.switch.ch/ftp/mirror/tex/macros/latex/contrib/savetrees/…) and then I changed \setlength\bibsep{0pt} (as suggested here: eng.cam.ac.uk/help/tpl/textprocessing/squeeze.html) since I'm using natbib. Greatly appreciate you pointing me in the right direction. –  crippledlambda Oct 2 '12 at 22:43
    
@crippledlambda -- thanks. I updated my answer (and my version of savetrees). I'm not sure why you need the \setlength command though: it won't make any difference in the example I posted. Though perhaps you are using other savetrees options or other packages that are interfering with your \bibsep settings.... –  jon Oct 2 '12 at 23:18
    
Thanks, @jon. That may be the case. At some point I will have to go through my (long) preamble to see what is causing a change in \bibsep. I'll report back if I figure this out... –  crippledlambda Oct 9 '12 at 1:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.