Sign up ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

For collaboration purposes I am using the draft mode in my LaTeX manuscript to show todo-notes, remarks and so on. By switching to final mode all of these additions become unvisible.

However, I'd love to switch on the final mode of the graphics/x package to see the actual pictures but \documentclass being still in draft mode. I get an error about clashing options when I add


My first guess was that the \documentclass already sets the option for the graphics/x package. Following doesn't help either

share|improve this question
Is there a place where rsauthor.cls can be examined? –  egreg Oct 1 '12 at 16:04
@egreg: It is freely available from the journal website: Proceedings of the Royal Society A - rsauthor.cls –  Hotschke Oct 1 '12 at 16:18
Suggestion: Add a tag for "trackchanges" (or mention it in the question so that searches find this better) –  TomOnTime Aug 8 '13 at 20:17
Suggestion: The title would be more readable as: "In graphics/graphicx, how to show actual pictures despite draft mode" –  TomOnTime Aug 8 '13 at 20:18
I am happy with your title suggestion. I've changed it. –  Hotschke Aug 9 '13 at 6:40

1 Answer 1

up vote 19 down vote accepted

probably works

Also (without doing that) you can flip the draft flag in the preamble as

share|improve this answer
no this doesn't help. Thanks for you help anyway. –  Hotschke Oct 1 '12 at 16:19
odd. what error does it give (I didn't have rsauthor class to test) –  David Carlisle Oct 1 '12 at 16:29
I tried with the rsauthor class and both methods work. The second seems preferable. –  egreg Oct 1 '12 at 16:31
@David Carlisle: the second suggestion with \setkeys works. Wow, thank you very much. I am always impressed by the fast and perfect help on –  Hotschke Oct 1 '12 at 16:47
The RequirePackage technique worked for me but I had to put that line before the \documentclass line. –  TomOnTime Aug 8 '13 at 20:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.