Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using texlive 2012, and both pdflatex and biber are executed with full path to ensure the correct binary.

biblatex has version 2.2, biber 0.9.9.

If I run pdflatex, biber, pdflatex I get the following output of biber

INFO - This is Biber 0.9.9
INFO - Logfile is 'LaTeXTemplate.blg'
INFO - Reading 'LaTeXTemplate.bcf'
WARN - Warning: Found biblatex control file version 2.0, expected version 1.7
INFO - Found 1 citekeys in bib section 0

and in the end I get the error from pdflatex

Package biblatex Info: Trying to load bibliographic data...
Package biblatex Warning: File 'LaTeXTemplate.bbl' is wrong format version - expected 2.1.

Package biblatex Info: ... file 'LaTeXTemplate.bbl' found.
(./LaTeXTemplate.bbl
! Undefined control sequence.
<argument> ...c@refsection @entry@\blx@slist@name 

What is going wrong ? I already deleted all biblatex and the aux file, but it is reproducible. Why is the bcf and bbl file version expected wrong?

share|improve this question

closed as too localized by Marco Daniel, lockstep, diabonas, zeroth, Stefan Kottwitz Oct 3 '12 at 16:37

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

5  
biber 0.9.9 isn't compatible with biblatex 2.2. Use tlmgr to upgrade biber 1.2. For a list of compatible releases refer to table 1 in the biblatex manual. –  Audrey Oct 3 '12 at 15:44
    
When I restarted the editor the correct biber (1.2) was used, though the path to the binary is the same. Strange. It works now. –  Matthias Pospiech Oct 3 '12 at 15:54

Browse other questions tagged or ask your own question.