Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

sometimes im using \lstinputlisting to show some code examples in my pdf. Now I just would like to insert a normal textfile. Everything is fine, I like this box around my text and the numbers every line. I just dont like that some string are bold. It's something like this:

12345 123 3123 3213H ABC12 AB 88789

So strings are bold. Somehow. I'm using \lstinputlisting{file.txt}. How can I change that? I mean highlighting is fine for my code, that's great but in this file I dont want this. Any ideas?

share|improve this question
1  
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. Use package filecontents (see texdoc filecontents) to include an example file file.txt. –  Kurt Oct 4 '12 at 18:50
    
Do you want a caption with this listing? If not, you can just use \input{file.txt}. –  Werner Oct 4 '12 at 18:52
1  
If you want plain text, with the option for a box around it and line numbers, you might consider fancyvrb. –  G. Poore Oct 4 '12 at 19:39
    
Since you have some responses below that seem to answer your question, please consider marking one of them as ‘Accepted’ by clicking on the tickmark below their vote count (see How do you accept an answer?). This shows which answer helped you most, and it assigns reputation points to the author of the answer (and to you!). It's part of this site's idea to identify good questions and answers through upvotes and acceptance of answers. –  Jubobs Mar 2 at 13:44

1 Answer 1

Perhaps you have set a language using \lstset. You can disable the language by using the empty language:

\lstinputlisting[language={}]{file.txt}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.