Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the glossary package for my PhD thesis. It works fine for me, but there is one little thing I want to change. On every glossary page, there is "Glossary" appear on the top left. It also appears in my reference page, since I put print the glossary before the reference. My question is how can I remove that word "glossary"?

I searched around, tried this:

\fancyhead[LE,LO]{}

I intend to remove the left heading for every page. But it doesn't work.

Any suggestions will be appreciated.


I am using the package glossary in my preamble I have:

\usepackage{glossary}
\makeglossary

In the text where I put my glossary page I used this command:

% this is adding my glossary into TOC
\addcontentsline{toc}{chapter}{\textmd{Glossary}}
% this is print out my glossary page
\printglossary

After the glossary I have my reference. To generate the glossary, after generating the PDF file from LyX, I have to run these commands:

makeindex phd_thesis.glo -s phd_thesis.ist -t phd_thesis.glg -o phd_thesis.gls
pdflatex phd_thesis.tex
pdflatex phd_thesis.tex

Every page on glossary and reference shows a "Glossary" on top left.

I am thinking before the \printglossary command put some command to get rid of the left heading. I searched around, haven't find any solution yet.

I am using LaTeX 2.9 and LyX 2.0.

share|improve this question

migrated from stackoverflow.com Oct 5 '12 at 20:38

This question came from our site for professional and enthusiast programmers.

    
Welcome to TeX.sx! Your question was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. –  Werner Oct 5 '12 at 20:39
    
Please compose a simple document showing the relevant settings (the document class used, the packages relevant to your problem, and an skeleton showing how you build the glossary and the bibliography) and add it to your question. –  Gonzalo Medina Oct 6 '12 at 1:15
    
Perhaps if you set the glossary name to empty things should work: \renewcommand*{\glossaryname}{} –  Peter Grill Oct 6 '12 at 5:47
    
The glossary package is obsolete; use the glossaries package instead. –  mhp Oct 6 '12 at 8:07
add comment

1 Answer

The glossary package is obsolete. So I’d recommend upgrading to its (much advanced) successor, the glossaries package (see this guide).

If I understand you right you want to get rid of the running header in the glossary section. Using the glossaries package, you can achieve this by redefining \glossarymark as an empty macro. Minimal example:

%% Process with pdflatex <document>; makeglossaries <document>; pdflatex <document>.

\documentclass{book}

\usepackage{glossaries}

\makeglossaries

\newglossaryentry{Test}{name={Test}, description={A Test}}

\renewcommand*{\glossarymark}[1]{}

\begin{document}

\printglossary

\newpage\gls{Test}\newpage\gls{Test}

\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.