Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the lipics document class. I want to use the hyperref package with this and pass some parameters to it. When I use this code,

\documentclass[a4paper,UKenglish]{lipics}
\usepackage[pdftex,bookmarks=false,pdfstartpage=5]{hyperref}

I am getting the following error:

! LaTeX Error: Option clash for package hyperref.

When I try the following code,

\documentclass[a4paper,UKenglish,hyperref={bookmarks=false,pdfstartpage=5}]{lipics}

I am getting 469 errors and the first one is:

! LaTeX Error: Missing \begin{document}.

What is the right way to combine lipics and hyperref?

share|improve this question
    
Welcome to TeX.SE. You could try \RequirePacakge[pdftex,bookmarks=false,pdfstartpage=5]{hyperref} before \documentclass? –  Peter Grill Oct 6 '12 at 15:27
    
@peter-grill: The code you mentioned, gives the following warning: Package hyperref Warning: Option 'pdfpagelabels' is turned off (hyperref) because \thepage is undefined. –  Arindam Pal Oct 7 '12 at 3:54
    
@peter-grill: and the following errors: ! LaTeX Error: Command \maketitle already defined. ! LaTeX Error: Command \appendix already defined. –  Arindam Pal Oct 7 '12 at 3:56
    
@Ok, I did not have the lipics class so was not able to test it myself. –  Peter Grill Oct 7 '12 at 4:07
add comment

1 Answer 1

up vote 4 down vote accepted

You can use \hypersetup:

\documentclass[a4paper,UKenglish]{lipics}
\hypersetup{bookmarks=false,pdfstartpage=5}
\begin{document}
test
\end{document}

This suppresses the errors, but still leaves a warning:

Package hyperref Warning: Option `bookmarks' has already been used, setting the option has no effect on input line 2

To suppress the bookmarks, you can use the bookmark package and its depth option:

\documentclass[a4paper,UKenglish]{lipics}
\hypersetup{pdfstartpage=5}
\usepackage[depth=0]{bookmark}
\usepackage{lipsum}% just to generate text for the example
\begin{document}
\section{test}
\lipsum[1-90]
\end{document}
share|improve this answer
    
This works fine. Thank you very much! –  Arindam Pal Oct 7 '12 at 4:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.