Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm new to latex, so this might just be a stupid error on my end, but I've downloaded the enumitem package and am trying to globally change the style of {enumerate} so that I don't have to type

\begin{enumerate}[label=(\roman*),itemsep=3pt,topsep=3pt]

every time I want to make a list. I've tried doing

\documentclass{article}
\usepackage{enumitem}
\listfiles
\setlist[enumerate]{label=(\roman*),itemsep=3pt,topsep=3pt}
\begin{document}
\begin{enumerate}
\item one
\item two
\end{enumerate}
\end{document}

but this doesn't change anything. Is there something I'm doing wrong?

EDIT: version: This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010)

EDIT: the information from \listfiles is as follows:

*File List*
article.cls    2007/10/19 v1.4h Standard LaTeX document class
size10.clo    2007/10/19 v1.4h Standard LaTeX file (size option)
enumitem.sty    2009/05/18 v2.2 Customized lists
keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
***********

EDIT: sorry for all these edits. I keep compiling my MWE and getting no change from the classic enumerate style, but if I try to change the enumerate style each time I use \begin{enumerate}, it changes the way I want it to. I honestly have no idea what I'm doing wrong.

I'm using TeXShop version 2.47.

share|improve this question
    
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. –  kan Oct 6 '12 at 19:40
    
I edited it, is that enough for a MWE? –  user19610 Oct 6 '12 at 19:49
1  
Your MWE produces the desired result on my machine. What exactly do you get with your example code? –  Gonzalo Medina Oct 6 '12 at 19:56
    
It produces: 1. one 2. two, just like the normal enumerate style, but when I change the enumerate style as I'm making the list, i.e. \begin{enumerate}[label=(\roman*),itemsep=3pt,topsep=3pt], I get my desired result. Is there some sort of problem with the rest of my preamble? I can post that too, it's not that long. –  user19610 Oct 6 '12 at 19:58
1  
Check whether your LaTeX compiler signals some errors. –  egreg Oct 6 '12 at 19:59
show 9 more comments

1 Answer

up vote 7 down vote accepted

Version 2.2 of enumitem used a different way to setup the standard lists; for your needs it should be

\setenumerate{label=(\roman*),itemsep=3pt,topsep=3pt}

If you downloaded the last version, you probably haven't put it in a place where the TeX system can find it and it uses the default one; I guess you installed the TeX distribution with MacTeX that always does a full installation.

If you want to use the last version, you need to properly install it, but beware that it may break. The best thing you can do is to update MacTeX to version 2012 (and run TeX Live Utility afterwards) that will bring the TeX distribution to the current state.

However, your setting is in any case not the best one, as LaTeX would use lowercase roman numbers for all enumerate levels. You should better say

\setenumerate{itemsep=3pt,topsep=3pt}
\setenumerate[1]{label=(\roman*)}

for enumitem version 2.2 or

\setlist[enumerate]{itemsep=3pt,topsep=3pt}
\setlist[enumerate,1]{label=(\roman*)}

for the current version. In this way the spacing parameters are used for every level, but roman numbers only for the first one.

share|improve this answer
    
Thank you so much. I'm sorry my unfamiliarity with LaTeX made my question confusing, but thank you for helping me through it! I think I must have only downloaded verison 2.2 of enumitem. For the document I need (review sheet for an exam), I only need one level for enumerate, so your first suggestion suffices, but I see your point and put in the second (better) suggestion. Thank you! –  user19610 Oct 6 '12 at 20:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.