TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have some footnotes in a ConTeXt document, which must be referenced too multiple times, i.e., the superscript mark 1 appears in several parts of the document, but the footnote is only displayed once, e.g.:

This is some text.^1

^1 This is the footnote text.

This is some more text.^1

With the stable edition of ConTeXt, this syntax worked:

    This is some text.\note[footnote][1]
        \setnotetext[footnote][1]{This is the footnote text.}
    This is some more text.\note[footnote][1]

With the current edition of ConTeXt, \setnotetext seems to correctly place the notes, however, \note seems no longer able to refer to my notes. After compiling, I get:

This is some text.^??

^1 This is the footnote text.

This is some more text.^??

I also tried the instructions found at the ConTeXt Garden article on footnotes, but the resulting compilation also creates ?? instead of numbering.

How can I create multiple references to a single footnote in the current version of ConTeXt?

share|improve this question

This works for me, using \footnote and \note in any order:

This is some text.\footnote[footnote]{This is the footnote text.}

This is some more text.\note[footnote]

This leaves the specification of the footnote symbol to ConTeXt. If you want to specify the number yourself, look at \defineconversion

\defineconversion[myset][list of comma separated symbols]

Does this solve your problem, or does some more specific use still not work?

share|improve this answer
That was with ConTeXt 2012? I tried just what you did by intuition (in current ConTeXt, 2013), but is still showing ?? instead of the footnote number... In fact, the ConTeXt output says "notes > internal error: note 1 of 'footnote' is not initialized" – acidrums4 Oct 3 '13 at 16:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.