Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I run the following code (using hyperref version 2012/09/27 v6.83g), I do not get any errors or warnings, but the metadata I set using pdfinfo doesn't appear. If I uncomment the \@firstofone line, effectively removing the group, it does.

I could not see any documentation in the manual that states one must be careful to use pdfinfo outside of all groups, so I have a feeling this might be a bug. Due to the grouping issue, I suspect this bug is caused by internal assignments in hyperref being local instead of global. I get a bit lost when reading the hyperref code, so I have so far been unable to determine the cause (and therefore a solution) to this problem.

\documentclass{article}
\usepackage{hyperref}

\makeatletter
%\@firstofone
{
    \hypersetup{pdfinfo={extrainfo={yes please}}}
}

\begin{document}
    Check the pdf metadata.
\end{document}

(Of course, in my actual example, I don't know how many levels deep I need to 'escape', and neither do I know any such way to escape! I cannot easily test my assumption about assignment locality as I am not aware of any trick to set a flag or something to make all assignments in a group global even if they were not defined \global, and I expect that may have other unwanted consequences anyway.)

Is anyone able to offer a fix or a workaround?

share|improve this question

closed as too localized by Martin Scharrer Oct 14 '12 at 7:04

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Oh, and I'm using the pdflatex workflow. –  cyberSingularity Oct 7 '12 at 11:14
    
If I use Author instead of extrainfo, the setting is respected independently of grouping. The "unknown" key instead is added only if at the outer level. –  egreg Oct 7 '12 at 11:20
    
Please send bug reports direct to the package author. A question and answer site isn't really the right place for bug reports. –  Martin Scharrer Oct 14 '12 at 7:06

1 Answer 1

up vote 5 down vote accepted

Fixed in hyperref 2012/10/11 v6.83h.

share|improve this answer
    
Confirmed. Thank you very much! (While I roughly understand the fix, I'm sorry I couldn't have been of more help in identifying the issue.) –  cyberSingularity Oct 12 '12 at 9:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.