Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

First post so please be gentle :)

I'm relatively new to Latex but have managed to bumble my way through using package manuals and stack exchange. But now I'm stuck on something I'm not sure how to solve... I've added in a code section that removes 'chapter' from the headings and contents, but not the contents seem to have this weird indent. How do I get rid of this indent?

Here is a picture:

ToC problem

The preamble is as follows:

\documentclass[a4paper, 11pt, oneside]{book}
% Include any additional packages
\usepackage[left=3cm, right=3cm, bottom=3.5cm, top=3.5cm]{geometry}
\usepackage[font=footnotesize, center]{caption}                                             % Changes font size of figure captions to small
\usepackage[
    backend=biber,
    style=authoryear-comp,
    natbib=true,
    maxnames=2,
    sorting=nyt,
    sortcites=false,
    block=space,
    date=long,
    url=false, 
    doi=false,
    eprint=false,
    isbn=false,
    uniquename=false,
    uniquelist=false,
    terseinits=true,
    firstinits=false
    ]{biblatex}
\addbibresource{../../BibTex/library.bib}
%Put initials after names...
\DeclareNameAlias{sortname}{last-first}
\DeclareNameAlias{default}{last-first}    
%Remove "and" before last name. However, this also removes "and" in a textcite...
\renewcommand*{\finalnamedelim}{\addcomma\space}
\usepackage{fancyhdr}  
\usepackage{graphicx}   
\usepackage{wrapfig}
\usepackage{sidecap}                                
\usepackage{subfig} 
\usepackage[big,compact]{titlesec}
\usepackage[hidelinks]{hyperref}
\hypersetup{
    pdftitle=Report,
        pdfauthor=EL,
        pdfkeywords=Thesis
        }
\usepackage[printonlyused]{acronym} % Automates the generation of an acronyms list
\makeindex
\renewcommand{\baselinestretch}{1.5}% Set document line spacing to 1.5
\setlength{\parindent}{0in}
\renewcommand{\chaptername}{}
\renewcommand{\thechapter}{}
\newcommand{\comment}[1]{}
share|improve this question
1  
Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Upvoting is the preferred way here to say "thank you" to users who helped you. –  lockstep Oct 8 '12 at 10:58
1  
If you have a picture, then use the "image" button to upload and include it, but remove the ! in front of what the system types. A user with enough privileges will be able to reinstate the image. –  egreg Oct 8 '12 at 11:04
    
lockstep: Sorry for the Thank You egreg: I've inserted the pic and removed the ! as per your instructions –  E_L Oct 8 '12 at 12:13

1 Answer 1

up vote 4 down vote accepted

If you want unnumbered chapters, just say

\setcounter{secnumdepth}{-1}

instead of clearing \chaptername and \thechapter.


By the way, setting \baselinestretch and \parindent is better done with the setspace and parskip packages. Of course my advice is to use neither increased baseline skip nor zero indentation: both hinder legibility.

share|improve this answer
    
The main reason I went with \parindent was due to the bibliography. We have to use this author-year style and if you use parskip, all the bibliography entries have no indent reducing readability. If I could keep the indent, or have some sort of bulletpoint/character denoting the start of each reference, then I might go with parskip. Is this possible? Has it been solved already? And do I need to create another question for it? –  E_L Oct 8 '12 at 13:12
    
@E_L This is a completely different question. –  egreg Oct 8 '12 at 13:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.