Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The following code produces headings on the section level starting with the number of the section before the bibliography:

\documentclass{scrbook}

\usepackage{csquotes}
\usepackage[english]{babel}
\usepackage[style=authoryear]{biblatex}
\bibliography{biblatex-examples}

\begin{document}

\nocite{westfahl:space}\nocite{aksin}\nocite{angenendt}
\nocite{baez/article}\nocite{bertram}\nocite{doody}
\nocite{matuz:doody}\nocite{gillies}\nocite{glashow}
\nocite{herrmann}\nocite{kastenholz}\nocite{reese}
\nocite{sarfraz}\nocite{kant:ku}\nocite{nietzsche:historie}
\nocite{brandt}\nocite{hyman}\nocite{pines}\nocite{moraux}
\nocite{salam}\nocite{cms}\nocite{baez/online}\nocite{ctan}
\nocite{itzhaki}\nocite{markey}\nocite{wassenberg}
\nocite{almendro}\nocite{kowalik}\nocite{laufenberg}
\nocite{sorace}\nocite{jcg}\nocite{chiu}\nocite{padhye}
\nocite{geer}\nocite{loh}

\printbibheading
\printbibliography[notkeyword=secondary,heading=subbibliography,title={Primary Sources}]
\printbibliography[keyword=secondary,heading=subbibliography,title={Secondary Sources}]

\end{document}

The resulting section header is "0.0 Secondary Sources"

on the top of page 3 while the header representing the chapter on the top of page 2 is correctly set to "Bibliography". The 0.0 seems wrong. How can I remove it? I tried several combinations with \defbibheading{subbibliography} but I did not succeed. (with biblatex 2.2, biber 1.2)

share|improve this question
1  
Were does your 0.0 apear? I tried your MWE and got no numbers 0.0. If I understand you right, try the class option bibliography=totocnumbered to get a numbered chapter bibliography in your TOC. Perhaps something missing in your MWE? –  Kurt Oct 8 '12 at 20:37
    
@Kurt I added the information to the question. For the MWE, it's on the top (header) part of page 3. I don't want to have the numbers. It is done correctly for the chapter heading on page two. –  sebschub Oct 8 '12 at 20:49
add comment

2 Answers 2

up vote 5 down vote accepted

biblatex.def defines

\defbibheading{subbibliography}[\refname]{%
  \section*{#1}%
  \if@twoside\markright{\sectionmarkformat#1}\fi}

for scrbook and scrreprt, which is responsible for the appearance of the number in the header. It disappears if you write, in your preamble,

\makeatletter
\defbibheading{subbibliography}[\refname]{%
  \section*{#1}%
  \if@twoside\markright{#1}\fi}
\makeatother

It should be probably filed as bug report to the maintainers of biblatex, as \section* is used, so no number should be printed in the header and \sectionmarkformat just prints the section number along with possibly a dot.

share|improve this answer
    
Thx! Typical case of me not to seeing the wood for the trees... I filed a report here. –  sebschub Oct 9 '12 at 5:46
    
This has been fixed in biblatex 2.3. –  sebschub Nov 20 '12 at 9:51
add comment

EDIT: So I was editing my answer and a better one was posted. See what is wrote by egreg.

If I understand well, you want only the name of the section (here Secondary sources), not the chapter and section numbers. You can do it with a tuning of the bibheading of biblatex with the following lines in your preamble:

\defbibheading{subbibliography}{
  \section*{#1}
  \markright{\itshape #1}
}

With your MWE it works. I don't know if it answers your question.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.