Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I get a warning every time I run bibtex on files using revtex4-1. The warning is

Warning--jnrlst (dependency: not reversed) set 1

This even happens with files revtex supplies as examples, but I've cut it down to a (nearly) minimal working example: SimpleTex.tex is

\documentclass[aps,prd,10pt]{revtex4-1}
\begin{document}
Refer to Ref.~\cite{ArticleKey}.
%\bibliographystyle{apsrev4-1}
\bibliography{SimpleBib}
\end{document}

and SimpleBib.bib is

@Article{ArticleKey,
  title =    {Cited work},
  journal =  "Awesomeness",
  author =   {Annie Author},
  year =     1999
}

Then, latex SimpleTex followed by bibtex SimpleTex gives me the warning. Interestingly, it appears to be using apsrev4-1.bst. But by explicitly giving the bibliographystyle (uncommenting the line in SimpleTex.tex), the warning goes away.

I realize that this is just a warning and could be ignored, but my automatic compilation scheme (emacs) complains that there's a warning every time, so I'd really like to get rid of it. Is it safe to just use the \bibliographystyle statement? Any idea why that appears to work?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Indeed it's just a warning and you are expected to ignore it. You could make it go away by arranging for SimpleTexNotes.bib to contain control lines:

@CONTROL{REVTEX41Control}
@CONTROL{apsrev41Control,author="48",editor="1",pages="0",title="",year="1"}

instead of the author="8" line that was there previously. This explicitly activates jnrlst rather than having it set as a dependency. For example you could have your build process run sed over the SimpleTexNotes.bib before running bibtex. Using bibliographystyle causes revtex to not emit the \citation{REVTEX41Control} \citation{apsrev41Control} lines to the aux file, since non-revtex bst files will not understand these. In this particular case the revtex4-1.bst defaults to the correct settings equivalent to @CONTROL{apsrev41Control,author="48",editor="1",pages="0",title="",year="1"} as desired, but in other cases it may not do as you would want. For example adding the longbibliography option to the \documentclass{revtex4-1} line would have no effect.

share|improve this answer
    
Ah, I was trying all kinds of things in that apsrev41Control block, but couldn't come up with author="48". Thanks. And thanks for the explanation, too! Anyway, I think I'll just stick with the explicit bibliographystyle statement, as that is easiest to implement. –  Mike Oct 10 '12 at 1:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.