Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

If \usepackage[T1]{fontenc} is used and parskip=half is set:

incorrect output

Else (either \usepackage[T1]{fontenc} isn't used or parskip=half isn't set):

correct output

I consider the second one the correct style. Why is there a problem when using parskip? And more importantly, why does fontenc influence anything here?

\documentclass[
    parskip=half
]{scrbook}

\usepackage[T1]{fontenc}
\usepackage[ansinew]{inputenc}
\usepackage{lmodern}

\usepackage[style=authoryear]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{biblatextest.bib}
@misc{A01,
  author = {Author, A. and Buthor, B.},
  year = {2001},
  title = {Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha },
}
@misc{A02,
  author = {Authora, A. and Buthora, B.},
  year = {2002},
  title = {Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta },
}
\end{filecontents}

\addbibresource{biblatextest.bib}

\begin{document}

Some text \cite{A01}. More... \cite{A02}.

\printbibliography

\end{document}
share|improve this question
add comment

2 Answers 2

up vote 10 down vote accepted

With biblatex, the hanging indentation of bibliographies is controlled by the \bibhang length which is initialized to the value of \parindent at the time biblatex is loaded. As a matter of principle, the class option parskip=half sets \parindent to 0pt, so \bibhang becomes 0pt, too. The remedy is either (as pointed out by Kurt) to set the parskip=half option after loading biblatex (using \KOMAoptions) or to manually set \bibhang to a suitable value.

Why does fontenc matter? Actually, the settings of the parskip option go in effect only after \selectfont has been issued. Without fontenc, the implicit issuing of \normalsize at the start of the document body will call \selectfont, but fontenc features its own \selectfont call.

share|improve this answer
    
So, can this be considered a biblatex bug? After all, those are not paragraphs in the bibliography. –  neo Oct 10 '12 at 8:08
    
@neo It's at least an unfortunate feature. –  lockstep Oct 10 '12 at 8:09
1  
By the way, I opened a bug ticket a while ago and this will be fixed in the next biblatex version: sourceforge.net/p/biblatex/bugs/172 –  neo Dec 7 '12 at 11:44
add comment

I do not exactly know why it happens but I have a workaround:

Use \KOMAoption{parskip}{half} instead of the class option parskip=half and it works for me (MiKTeX 2.9).

Test it with the following, a little bit changed MWE:

%http://tex.stackexchange.com/questions/76029/why-doesnt-parskip-half-work-together-with-fontenc-in-bibliographies
\documentclass[%
  paper=a4
%,parskip=half
]{scrbook}

\usepackage[T1]{fontenc}
\usepackage[ansinew]{inputenc}
\usepackage{lmodern}

\usepackage[style=authoryear,natbib]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{A01,
  author = {Author, A. and Buthor, B.},
  year = {2001},
  title = {Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha Alpha },
}
@misc{A02,
  author = {Authora, A. and Buthora, B.},
  year = {2002},
  title = {Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta Beta },
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}
\KOMAoption{parskip}{half}
%\KOMAoptions{parskip=half}

Some text \cite{A01}. More... \cite{A02}. More text. More text. More text. More text. More text. 
More text. More text. More text. More text. More text. More text. More text. More text. More text. 

More text. More text. More text. More text. More text. More text. More text. More text. More text. 
More text. More text. More text. More text. More text. More text. More text. More text. More text. 
More text. More text. More text. More text. More text. More text. More text. More text. More text. 

\printbibliography

\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.