Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Is it possible to modify the title page from its default in LaTeX? Example:

\documentclass[pdftex,12pt,a4paper,english,dutch,leqno]{article}
\usepackage[utf8]{inputenc}
\usepackage{authblk}
    %title and author details
    \title{This is the title for my work}
    \author[1]{Name1}
    \author[1]{Name2}
    \affil[1]{Address of author}
    \renewcommand\Authands{ and }
    \date{} %remove date

\begin{document}
\maketitle
\end{document}

I would like to alter this so that the title page was left orientated (i.e. not centered) and that the font size was the same as the remainder of the document. How can this be achieved?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

Using authblk is a good idea, but it still exploits the standard \maketitle command, which centers. So we have to patch it.

\documentclass[12pt,a4paper]{article}
\usepackage{lipsum}
\usepackage{authblk,etoolbox}

\makeatletter
% patch \maketitle so that it doesn't center
\patchcmd{\@maketitle}{center}{flushleft}{}{}
\patchcmd{\@maketitle}{center}{flushleft}{}{}
% patch \maketitle so that the font size for the title is normal
\patchcmd{\@maketitle}{\LARGE}{\normalsize}{}{}

% patch the patch by authblk so that the author block is flush left
\def\maketitle{{%
  \renewenvironment{tabular}[2][]
    {\begin{flushleft}}
    {\end{flushleft}}
  \AB@maketitle}}
\makeatother

% a couple of other settings
\renewcommand\Authands{ and }
\renewcommand\Authfont{\normalfont\normalsize}
\renewcommand\Affilfont{\normalfont\normalsize}

\begin{document}

%title and author details
\title{This is the title for my work}
\author[1]{Name1}
\author[1]{Name2}
\affil[1]{Address of author}
\date{} %remove date

\maketitle

\lipsum[1]
\end{document}

enter image description here

As you can see, the title seems not to be sufficiently highlighted, so you may prefer to use something else in the third \patchcmd, for example \normalsize\bfseries or \large

share|improve this answer
add comment

You should redefine the macro \maketitle or use the environment titlepage (see example at http://theoval.cmp.uea.ac.uk/~nlct/latex/thesis/node18.html)

    \documentclass[pdftex,12pt,a4paper,english,dutch,leqno]{article}
    \usepackage[utf8]{inputenc}

    \renewcommand{\maketitle}{%
            \textbf{This is the title of my work}
            \par \vspace{.5ex}
            Name1 and Name2
            \par
            \textsl{Address of author}
            \par
            \hrulefill\par \vspace{2ex}
    }

    \begin{document}

    \maketitle
    Test

    \end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.