TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using currently using bibtex and the \cite{...} command for all citations. Using the cell bibliography style, citations will appear as e.g. [Jovanović and Janičić, 2005].

However, I would like to be able to extract only the author part or the year part -- like natbib's \citeauthor and \citeyear. The reasons I don't want to use natbib are: 1) natbib changes the overall citation style to not include the brackets [] around the citation; 2) natbib doesn't support UTF-8 in the bibliography file; and 3) \citeyear still doesn't output a letter if the same authors published multiple papers in the same year.

share|improve this question
Try biblatex together with biber. Together, they support \citeauthor and \citeyear out of the box. UTF-8 is the main encoding used by biblatex/biber. – koppor Nov 2 '15 at 5:55
up vote 5 down vote accepted

Your second observation, that "natbib doesn't support UTF-8 in the bibliography file", isn't quite accurate: it is bibtex, not natbib, that suffers from the ASCII-128 limitation. If you can run bibtex8 instead of bibtex, you can use many more Latin alphabet based character encodings.

Regarding your points 1 and 3: I'm not sure what the concerns you raise are founded on. (You did issue the command \bibliographystyle{cell}, right?) To get natbib to place square brackets rather than round parentheses around the author,year pair, just load the package with the square option and use the \citep command (for "parenthetical citations").

The output of the MWE below shows that \citeyear and \citeauthor work as one would expect them to. In particular, natbib knows perfectly well how to append a, b, etc automatically to the year if the need to do so arises.

enter image description here

Here's the "cellcite.tex" driver file:





Finally, the MWE's bib file ("cellcite.bib"):

  author      = "Torben G. Andersen and Tim Bollerslev and 
                Peter F. Christoffersen and Francis X. 
  title       = "Volatility and correlation forecasting",
  chapter     = 15,
  pages       = "777--878",
  editor      = "Graham Elliott and Clive W. J. Granger and 
                Allan Timmermann",
  booktitle   = "Handbook of Economic Forecasting, 
  publisher   = "Elsevier",
  address     = "Amsterdam",
  year        = 2006,

  author      = "Torben G. Andersen and Tim Bollerslev and 
                Peter F. Christoffersen and Francis X. 
  title       = "Practical volatility and correlation 
                modeling for financial market risk 
                management (with discussion)",
  chapter     = 11,
  pages       = "513--548",
  editor      = "Mark S. Carey and Ren{\'e} M. Stulz",
  booktitle   = "The Risks of Financial Institutions",
  publisher   = "University of Chicago Press",
  address     = "Chicago and London",
  year        = 2006,
share|improve this answer
I tried changing bibtex to bibtex8 and it will complain about č only if I use natbib (without, it is fine). This is why I concluded that it is natbib rather than bibtex which doesn't handle UTF-8. – Vegard Oct 11 '12 at 16:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.