Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using TeXStudio on Mac OS X 10.7.4.

The problem is that the EPS to PDF conversion is somehow broken:

\usepackage[pdftex]{graphicx}
\graphicspath{{img/}}
\DeclareGraphicsExtensions{.pdf,.jpeg,.png}
...
\begin{figure}[!t]
\centering
\includegraphics[width=3.5in]{TCP_VC_TD_AVE_CONNS_ACT}
\caption{Simulation Results}
\label{fig_sim}
\end{figure}
...

I've got an EPS file in: img/TCP_VC_TD_AVE_CONNS_ACT.eps

Log:

Package epstopdf Info: Source file: <img/TCP_VC_TD_AVE_CONNS_ACT.eps>
(epstopdf)                    date: 2012-10-12 16:44:32
(epstopdf)                    size: 210073 bytes
(epstopdf)             Output file: <img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-
to.pdf>
(epstopdf)             Command: <epstopdf --outfile=img/TCP_VC_TD_AVE_CONNS_ACT
-eps-converted-to.pdf img/TCP_VC_TD_AVE_CONNS_ACT.eps>
(epstopdf)             \includegraphics on input line 94.
runsystem(epstopdf --outfile=img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-to.pdf i
mg/TCP_VC_TD_AVE_CONNS_ACT.eps)...executed.

Package epstopdf Info: Result file: <img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-
to.pdf>.

! Package pdftex.def Error: File `img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-to.
pdf' not found.

The required img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-to.pdf file is never created.

TeXStudio compiles with (I've added -shell-escape, from other posts):

/usr/texbin/pdflatex -synctex=1 -interaction=nonstopmode -shell-escape %.tex

Can anybody assist?

EDIT - A minimal file breaks as well:

\documentclass{article}
\usepackage{graphicx}
\begin{document}
\includegraphics{img/TCP_VC_TD_AVE_CONNS_ACT.eps}
\end{document}

Log:

Package epstopdf Info: Source file: <img/TCP_VC_TD_AVE_CONNS_ACT.eps>
(epstopdf)                    date: 2012-10-12 16:44:32
(epstopdf)                    size: 210073 bytes
(epstopdf)             Output file: <img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-
to.pdf>
(epstopdf)             Command: <epstopdf --outfile=img/TCP_VC_TD_AVE_CONNS_ACT
-eps-converted-to.pdf img/TCP_VC_TD_AVE_CONNS_ACT.eps>
(epstopdf)             \includegraphics on input line 4.
runsystem(epstopdf --outfile=img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-to.pdf i
mg/TCP_VC_TD_AVE_CONNS_ACT.eps)...executed.

Package epstopdf Info: Result file: <img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-
to.pdf>.

! Package pdftex.def Error: File `img/TCP_VC_TD_AVE_CONNS_ACT-eps-converted-to.
pdf' not found.
share|improve this question
    
Welcome to TeX.sx! Just a wild guess: Have you tried it without \graphicspath{{img/}}? On an unrelated note: specifying pdftex for graphicx is usually not necessary; it can figure that out by itself. –  doncherry Oct 12 '12 at 16:26
    
I have no problem. Can you try with no other package other than graphicx? Just the \includegraphics command should be in the test file. The -shell-escape option is not needed. –  egreg Oct 12 '12 at 16:29
    
@doncherry Tried that - same problem. –  Nic Oct 12 '12 at 16:39
    
@egreg Tried with a minimal file as well, still the same problem. –  Nic Oct 12 '12 at 16:41
1  
UPDATE: This looks like a TeXStudio issue, everything works fine in Texpad! –  Nic Oct 12 '12 at 17:24

5 Answers 5

epstopdf is sometimes trying to write in the wrong directory and then fails to create the file (on certain editors at least, I had a similar problem with WinEDT). Place the following code in the header:

\epstopdfsetup{outdir=./}
share|improve this answer
1  
This worked for me - but don't forget (as I did initially) that you still need to add \usepackage{epstopdf} first. –  drstevok Feb 22 '13 at 14:12
    
\usepackage[outdir=./]{epstopdf} also works and saves you one line :) –  Trefex Apr 17 at 8:11

The following worked for me:

Open TeXstudio, go to 'Preferences' --> 'Build' (Somehow all my list entries are in german, so I only guess it should be named Build - in german it's 'Erzeugen', the third entry from the top). At the bottom you can specify additional search paths. Make sure the specified search path really exists. In my case the path pointed to a texlive 2012 directory even though I have only installed the 2013 version. After changing the path to the 2013 version everything worked fine! :-)

share|improve this answer

I have exactly the same problem as the poster's log. Common solutions around Internet have adding epstopdf or epsfig package, appending -shell-escape option to pdflatex commandline. But both methods failed to me. I post my solution on Mac OS X 10.09 + texlive2013 + TeXsdudio2.7.

By checking the tex's log, I found that epstopdf was not located in system searched PATH, so I created the link manully

ln -s /usr/local/texlive/2013/texmf-dist/scripts/epstopdf/epstopdf.pl /usr/local/bin/epstopdf

Also, the epstopdf complained that ghostscript is not installed. So I made it satisfied with

brew install ghostscript

WHooo, texstudio generated pdf as I expected.

PSPS: requiring epstopdfpackage declared and -shell-escape appended.

share|improve this answer
1  
But on my linux/ubuntu, only epstopdf and -shell-escape are needed. –  caesar0301 Apr 17 at 3:23

Use

$ latex file.tex

This will result in output as file.dvi and then use

$ dvi2pdf file.dvi
share|improve this answer
1  
The OP uses pdfTeX (pdflatex). A different driver might support a different set of image formats that does not fit the OPs need. –  Heiko Oberdiek Sep 12 '13 at 17:48
    
Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. –  Heiko Oberdiek Sep 12 '13 at 17:50
    
...and therefore I don't think this answers the question... –  Werner Sep 12 '13 at 17:52

I encountered the same issue when utilizing esptopdf on a Windows 8.1 virtual machine running in Parallels on my Mac. Either TeXstudio or MiKTeX doesn't like UNC paths (ie \\psf\DropBox), which was how I had loaded my main *.tex. The included tex files used relative paths since I work across multiple machines, so that probably compounded the problem.

To remedy this I just needed to use a mapped drive name for the same shared network path (ie. Z:\DropBox). The only clue that this was the source of the problem came from the Messages tab that indicated:

... CMD.EXE was started with the above path as the current directory. 
UNC paths are not supported. Defaulting to Windows Directory.

Changing to a regular file path eliminated this message and allowed the new EPS files to be generated into PDF files that Pdflatex could interpret.

As a reference, I was using Windows 8.1, TeXstudio 2.8.4, and MiKTeX 2.9.4902.

You may also want to specify a directory other than the current folder for epstopdf to save pdf files to:

 \include[outdir=./(folder)/]{epstopdf}

This is optional, but if you only specify output=./ the directory with the .tex file will be the target for all of the generated PDF's even if you keep the *.eps files organized in another folder.

share|improve this answer

protected by Community Dec 3 at 15:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.