Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In using TeXStudio to edit my text file under Debian, I have a problem in locating the cursor while using the auto-completer to complete a pair of braces. There is a little box frame holding the place of the right brace, and the edges of the box cover the shining cursor when the cursor moves to one of the edges of the box frame. Therefore, I cannot distinguish whether the cursor is on the left or right side of the box frame. It is especially annoying when I want to delete a brace because I don't know where the cursor is at that moment. How can I solve this?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

I use TeXstudio also. I don't know if this is what you want but:

Menu options>configure. Then you can edit your completion tools.

Disable the option use placeholders (or some similar, I don't use it in English). See the image below and the option above the field with 100%.

enter image description here

share|improve this answer
1  
The option is called “Use Placeholders”. –  Qrrbrbirlbel Oct 14 '12 at 15:46
    
I have updated texstudio from 2.4 to 2.5. Then the position of cursor is in the right place, which is for my purpose. –  azhi Oct 20 '12 at 12:45
add comment

This is fixed in the recent SVN version (the cursor is wider).

A quick workaround: Ctrl+Shift+K (Idefix → Remove Placeholders)

share|improve this answer
    
Thank you Qrrbibirlbel, with your suggestion, I can "Remove Placeholders" by Ctrl+Shift+K. But how can I disable this function permanently, so that I can not press Ctrl+Shift+K any more? Actually I can not find any use of the Placeholders at present. –  azhi Oct 16 '12 at 1:32
    
@azhi Does Sigur's answer help you there? Unfortunately, such “placeholder” box is also drawn when you use the option auto-complete braces ({{})—even if Sigur's tip is followed—, so deactivating “Auto-complete braces” could help but also takes away that functionality. Maybe a short message to the developers is more helpful … –  Qrrbrbirlbel Oct 16 '12 at 17:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.