Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use the hyperref package with the memoir class but the bottom margin of the document is no longer 2 cm as I set it. Rather, it seems like there is no margin at all. When I remove the hyperref package, the margins are reset to the correct value. What should I do? I'm using the memoir class in LyX and then I add the following to the preamble:

\openany

\midsloppy

\setlength{\parskip}{0cm}

\clubpenalty=10000
\widowpenalty=10000
\raggedbottom

\usepackage{babel}
\frenchbsetup{FrenchFootnotes=false,AutoSpaceFootnotes=false,AutoSpacePunctuation=false}

\usepackage{hyperref}
share|improve this question
1  
Welcome to TeX.SE! Please consider editing the code you provided to show the actual margin-setting commands. As of now, it's not possible to tell how the margins are being set. By the way, the \raggedbottom directive allows a page to have a bottom margin that's larger, but no smaller, than the specified value of that parameter. –  Mico Oct 15 '12 at 10:50
    
I haven't specified any code for the margins in the document. They are set in the dedicated LyX window (Top: 2cm, Bottom: 2cm, Left: 2.5cm, Right: 2.5cm). If I omit the hyperref package, they are preserved. If I add the hyperref, everything is still working, except that the bottom margin is missing. It's like if I have set it to 0. –  Nikos Oct 15 '12 at 11:08

1 Answer 1

up vote 2 down vote accepted

Package hyperref page size setting can be disabled by

\usepackage[setpagesize=false]{hyperref}
share|improve this answer
    
With more information (MWE, driver, ...) I could investigate further. Usually hyperref supports memoir and vice versa. –  Heiko Oberdiek Oct 15 '12 at 12:45
    
The setpagesize option works! Thanks a lot! –  Nikos Oct 15 '12 at 13:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.