Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to typeset math in different font called Antykwa Torunska, which supports maths. Unfortunately, when using it in beamer the math font is switched to the standard math font of beamer. How can I change this behaviour?

Here is a minimal example:

\documentclass{beamer}
% Mathekram:
\usepackage{amssymb, amstext, amsmath}
% Font:
\usepackage[math]{anttor}
\usepackage[T1]{fontenc}


\begin{document}

\begin{frame}{Testframe}
   This is fine: 1234567890, \textit{x}, \textit{p}, \textit{t}\\
   This is not fine: $1234567890$, $x$, $p$, $t$
\end{frame}

\end{document}

When I change beamer to article it works fine.

share|improve this question
    
I can confirm this on TeXLive 2012 under mac. –  Dror Oct 15 '12 at 11:24

2 Answers 2

up vote 5 down vote accepted

You should add \usefonttheme{professionalfonts} to your preamble or use the professionalfonts class option, in order to suppress any font replacements performed by beamer.

share|improve this answer

I think you just need to add the [professionalfont] option to your \documentclass command. See section 18.1 of the beamer documentation for details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.