Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I realize Arabic in ConTeXt with the following environment (to be able to switch between German and Arabic).

\startenvironment arab-besser-sty
\definefont[Sheh][name:Scheherazade*arabic at 15pt] % or file:amiri-regular.ttf*... file:alq.ttf
\definestartstop[Arab][commands=\setups{Arabic}]
\def\Arab{\doArab}
\def\Arab[#1]{
\startArab 
\setupalign[r2l]\Sheh #1
\stopArab
}

\stopenvironment

Everything works fine, but with my Standard-Setup:

\environment arab-besser-sty

\setuplayout[location=middle,
topspace=1cm,
width=middle,
cutspace=2.7cm,
rightmargindistance=0.4cm,
leftmargindistance=0.2cm,
backspace=1.5cm,
height=fit,
rightmargin=2.5cm,
leftmargin=1cm,
bottomspace=1.5cm,
footer=1.2cm,
grid=yes]

The line-space between arabic lines is far too much, why, and how to fix this without disturbing the above standard-layout?

Full Minimal Example:

    \environment arab-besser-sty

\setuplayout[location=middle,
  topspace=1cm,
  width=middle,
  cutspace=2.7cm,
  rightmargindistance=0.4cm,
  leftmargindistance=0.2cm,
  backspace=1.5cm,
  height=fit,
  rightmargin=2.5cm,
  leftmargin=1cm,
  bottomspace=1.5cm,
  footer=1.2cm,
  grid=yes]

\starttext

\Arab[

يَـٰٓأَيُّهَا ٱلنَّاسُ ٱتَّقُوا۟ رَ‌بَّكُمُ ٱلَّذِى خَلَقَكُم مِّن نَّفْسٍ وَٰحِدَةٍ وَخَلَقَ مِنْهَا زَوْجَهَا وَبَثَّ مِنْهُمَا رِ‌جَالًا كَثِيرً‌ۭا وَنِسَآءً وَٱتَّقُوا۟ ٱللَّـهَ ٱلَّذِى تَسَآءَلُونَ بِهِۦ وَٱلْأَرْ‌حَامَ إِنَّ ٱللَّـهَ كَانَ عَلَيْكُمْ رَ‌قِيبًا ﴿١﴾ وَءَاتُوا۟ ٱلْيَتَـٰمَىٰٓ أَمْوَٰلَهُمْ وَلَا تَتَبَدَّلُوا۟ ٱلْخَبِيثَ بِٱلطَّيِّبِ وَلَا تَأْكُلُوٓا۟ أَمْوَٰلَهُمْ إِلَىٰٓ أَمْوَٰلِكُمْ إِنَّهُۥ كَانَ حُوبًا كَبِيرً‌ۭا ﴿٢﴾ وَإِنْ خِفْتُمْ أَلَّا تُقْسِطُوا۟ فِى ٱلْيَتَـٰمَىٰ فَٱنكِحُوا۟ مَا طَابَ لَكُم
]

Too much line space above.

\stoptext
share|improve this question
    
Add: How to disable grid=yes for a command like the above \Arab? I think that would solve this. –  Mustafa Oct 16 '12 at 11:04
add comment

1 Answer

up vote 1 down vote accepted

I found one solution. I set the environment Arab into \placeongrid[bottom]{...}, that works quite well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.