Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having some weird trouble with the tikzrput package.

I use it on my Macbook with TeX Live and it works perfectly. On the other hand on my Ubuntu at work (with TeX Live too) it really does not want to work.

Every \rput line gives me after compilation something like:

Undefined control sequence \rput{0}(0,3.5){$\lambda$}

I fear it is not a problem of integrating tikzrput.sty because when I remove it, the error turns into only:

Undefined control sequence \rput

Without those \rput lines, everything works fine (TikZ is well installed along with pgf on my Ubuntu).

Could this be a problem of compatibility between tikzrput and my TikZ version? (everything is upgraded to the last version).

share|improve this question

closed as too localized by Stephen, Stefan Kottwitz Oct 16 '12 at 16:29

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to TeX.SX. A tip: If you indent lines by 4 spaces, then they're marked as a code sample. You can also highlight the code and click the "code" button ({}). –  Claudio Fiandrino Oct 16 '12 at 15:57
    
Thank you very much, I will use that from now on. –  Laurent Oct 16 '12 at 15:58
    
Did you see Problem with keys to emulate \rput with TikZ? I've created a folder which contains tikzrput.sty from the answer and a test-tikzrput.tex copying again the example provided by Alain Matthes. It works! –  Claudio Fiandrino Oct 16 '12 at 16:04
    
Okay, now that's really weird : I deleted and downloaded tikzrput.sty many times and it never worked. This time I created it myself by pasting the code from Alain Matthes in my own tikzrput.sty, and everything works fine ! –  Laurent Oct 16 '12 at 16:10
add comment

Browse other questions tagged or ask your own question.