Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the longtable package to generate tables that may extend past a single page, and I am coming up with a strange format on particular tables. The table itself looks like this: Picture of table generated

And here is the code I used to generate it:

\begin{longtable}{| l | l || r |} 
\hline
\emph{Tag} & \emph{Name} & \emph{Percent Complete} \\
\hline

aaaaaaaaaaaaaaaaaaa & bbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaa & bbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaa & bbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaa & bbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb & 100.0\% \\ 
aaaaaa & bbbbbbb & 50.0\% \\ 
aaaaaa & bbbbbbb & 50.0\% \\ 
aaaaaaaaaa & bbbbbbbbbbbbbbbbbbbbbbbbbbb & 0.0\% \\ 
\hline
\end{longtable} 

So why is the width of the table suddenly expanded to the right about 3/4 of the way down? Am I missing something, or is there something that isn't being formatted correctly?

share|improve this question
    
Your fonts are low-res :P –  percusse Oct 18 '12 at 19:57

1 Answer 1

up vote 2 down vote accepted

That's as expected, just re-run LaTeX until it stops asking you to re-run and everything will be OK, I promise:-)

share|improve this answer
    
The problem is this is scripted and uses pdflatex - I'm not sure if I can detect when a re-run is needed or not. –  nuclearpenguin Oct 18 '12 at 20:06
    
@nuclearpenguin: I would just add a couple of recompiles by default then and not worry about detection. There's also latexmk for this. –  Werner Oct 18 '12 at 20:11
    
Adding a second recompile does seem to fix the issue. Thanks! –  nuclearpenguin Oct 18 '12 at 20:14
    
well you can run it 2 or three times anyway or you can grep for "rerun latex" in the log file or you can save the log file from the last run and re-run until the log file shows no diff or... –  David Carlisle Oct 18 '12 at 20:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.