Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

So my problem is whenever I try to use the algorthmic package, it gives me an error related to citations! And when I comment out the algorithmic block, everything works fine.

I read somewhere that algorithmic is not compatible with hyperref, if that is the case how should I fix it ?

share|improve this question
1  
Please provide a "Minimum Working Example", some LaTeX code that we can copy-paste to try to reproduce your problem. Please also show the exact error message that you get. –  gerrit Oct 21 '12 at 16:59
1  
We cannot help you without a MWE. One thing: the packages are order-dependent, so try to load algorithmic before hyperref. –  tohecz Oct 21 '12 at 17:09
1  
Hi SalamKh Welcome to TeX.SE! :) As the other users have mentioned, it is always best to provide a MWE The process of constructing a MWE will quite often help to solve the problem, or at the very least isolate it :) Welcome to the group! –  cmhughes Oct 21 '12 at 17:38
    
Ok, I did not know about the MWE, sorry. I just solved my problem, I did not know that \STATE is case sensitive. Thanks anyways –  SalamKh Oct 21 '12 at 17:40
add comment

closed as too localized by lockstep, Kurt, Stefan Kottwitz Oct 21 '12 at 18:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.