Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to create a table of contents, but it doesn't show up. I use the beamer documentclass. My code looks like this:

\documentclass[12pt]{beamer}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage{amsmath, amsfonts, amssymb}

\setbeamertemplate{footline}[frame number]
\usetheme[secheader]{Boadilla}
\beamertemplatenavigationsymbolsempty
\title{...}
\author{...}
\date{\today}

\begin{document}

\begin{frame}
    \titlepage
\end{frame}

\begin{frame}
        \tableofcontents
\end{frame}

\section{Section1}

\begin{frame}
\end{frame}

\section{Section2}

\begin{frame}
\end{frame}

\end{document}
share|improve this question

closed as too localized by lockstep, Torbjørn T., cmhughes, percusse, Qrrbrbirlbel Oct 22 '12 at 17:13

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You need to compile it atleast two times to get the TOC. –  Harish Kumar Oct 22 '12 at 15:30
    
I just compiled the example document given by you and all worked out fine for me. TOC showed up after the second compilation. –  Benedikt Bauer Oct 22 '12 at 15:31
    
Compilation: See tex.stackexchange.com/a/1606/510 –  lockstep Oct 22 '12 at 15:37
    
Then something must be not ok here. I compiled it at least three times and it still doesn't show up. –  Stan Oct 22 '12 at 15:37
1  
Are you sure not having enabled some "automatic clean up" action after the compilation? What are you using for compiling the file? –  egreg Oct 22 '12 at 15:46

Browse other questions tagged or ask your own question.