Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question deals with the version of a babel language available after a MiKTeX update (the french one, namely frenchb.dtx). I've just made an update of my (complete) MiKTeX 2.9, especially interested in the package menukeys and in frenchb; the result of the update is (with a \listfiles):

  • frenchb.ldf 2009/03/16 v2.3d
  • menukeys.sty 2012/04/11 v1.1b

However, menukeys requires a feature from a more recent frenchb to avoid a ''french bug'' (if not mistaken, on CTAN there is frenchb.dtx 2010/08/21 v2.5a).

Questions: does my problem (= not having a recent enough version of frenchb after a MiKTeX update) come from MiKTeX? If yes, could MiKTeX provide that version 2.5? or is there something preventing it?

(My temporary solution is to manually update frenchb as suggested by its author... it works fine but I still wonder why I can't get it from the MiKTeX update).

share|improve this question
    
Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Upvoting is the preferred way here to say "thank you" to users who helped you. –  Kurt Oct 24 '12 at 17:31
3  
The current version of frenchb (on the website of the author) is 2012/05/08 v2.5j. So the version on CTAN is outdated too. Beside this: It sometimes happens that miktex (and TeXLive too) forgets to package an updated package. Make a bug report or a feature request. –  Ulrike Fischer Oct 24 '12 at 17:41
    
Are you sure to have MiKTeX 2.9? –  egreg Oct 24 '12 at 18:01
    
@egreg: No, both Mathieu (?) and Ulrike are right. –  Speravir Oct 24 '12 at 18:33
    
@UlrikeFischer: Feature request done (you did mean on MiKTeX homepage?). –  mathieu2l Oct 24 '12 at 20:28

1 Answer 1

My MiKTeX paket manager shows the used babel is from 2011-07-11, a frenchb is not separatly listed, but there is a package frenchle from 2012-06-11 usable with or without babel.

To use package frenchb the installation in the local texmf tree seems actualy to be the best.

I think the best place to ask is the maintainer of MiKTeX on the MiKTeX homepage.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.