Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Every time I run pdflatex my whole home directory is scanned. It takes forever and one cpu core is at 100% usage.

I'm using Ubuntu 12.04 TeXLive packages and can't find where this is set.

kpsepath tex | tr ':' '\n' does not list my home directory directly only ~/texmf and ~/.texmf.

Please help.

share|improve this question
1  
It would be helpfull to add the version number of your tex distribution (actuall is 2012) and how you installed the distribution. How do you know that your complete home directory is scanned (I have no Ubuntu)? –  Kurt Oct 26 '12 at 15:42
    
For completeness texlive-binaries is 2009-11ubuntu2. And I can tell that the whole directory is scanned by using strace. –  tauran Oct 27 '12 at 11:46

1 Answer 1

up vote 4 down vote accepted

You very likely have your $HOME containing a final slash /. This expands to // after $HOME in the definition of $TEXMF and thus all of your home is searched.

By default $HOME does not contain this final /, so it might have been added locally in your init files.

Other than that, on Debian/Ubuntu TeX Live you change settings by adding lines to /etc/texmf/web2c/texmf.cnf (creating if necessary).

share|improve this answer
    
I had to remove the final / in /etc/passwd as that is the source for $HOME. Very annoying... –  tauran Oct 27 '12 at 11:44
    
@tauran /etc/passwd should never have trailing slashes on directory names anyway so a bonus side effect of this problem is that you got your system cleaned up. –  Caleb May 12 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.