Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

My auctex renders preview images on my debian stable system (6.0.6) if I set it to dvi mode, but it fails if I set auctex to pdf mode.

auctex renders preview images on my debian stable system auctex fails if i set it to pdf mode

I assume there is either a mistake in my emacs configuration or a permanent bug in the ghostscript package.

I need help to isolate the bug step by step. Additionally I would be glad, if someone with the same software could help me out with his configuration.

Perhaps it will help, if I can upgrade the ghostscript package, but I have no idea how to do this as I found no backport yet.

My complete emacs configuration is available on github.

$ ghostscript --version
8.71
$ emacs-snapshot --version
GNU Emacs 24.2.50.1
$ pdftex --version
pdfTeX 3.1415926-1.40.10-2.2 (TeX Live 2009/Debian)
share|improve this question
1  
Direct PDF output does not use GhostScript, nor does it produce .dvi files (which are needed by preview). I'm therefore wondering if this can possibly work! –  Joseph Wright Oct 27 '12 at 18:25
    
If PDF output denies preview, preview should ignore the [x] Generate PDF checkbox and just do its job with the .dvi settings. –  Jonas Stein Oct 27 '12 at 19:32

1 Answer 1

up vote 2 down vote accepted

Direct PDF output does not use GhostScript, nor does it produce .dvi files (which are needed by preview). Thus this is probably a bug in AUCTeX: the options should not allow 'Create a PDF' with direct PDF output.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.