TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I experienced that glossaries generates a wrong link when my document contains a titlepage...

Here is my code:


\newglossaryentry{api}{type=\acronymtype, name={API}, description={Application
Programming Interface}, first={Application
Programming Interface (API)}, see=[Glossary:]{apig}}

description={An Application Programming Interface (API) is a particular set
of rules and specifications that a software program can follow to access and
make use of the services and resources provided by another particular     software
program that implements that API},nonumberlist}

First use \gls{api}\\
subsequent \gls{api}
a page between
Another use: \gls{api}\\



I took the code from here: How to combine Acronym and Glossary

I want to have acronyms and a glossary. And the acronyms should link to the glossary...

I won't mind to remove the page number behind the acronym, but using the "nonumberlist" option also removes the link to my glossary :-/

Using the code without the titlepage works fine...

Thanks for help!

share|improve this question

closed as too localized by Harish Kumar, Kurt, Stefan Kottwitz Oct 30 '12 at 6:08

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Welcome to TeX.sx! – Andrew Swann Oct 29 '12 at 18:52
The problem is that you have two pages "number 1". A workaround is to say \pagenumbering{alph} before the titlepage and \pagenumbering{arabic} just after it. – egreg Oct 29 '12 at 18:56
Damn^^ I just found that a few seconds ago and was trying to post an answer for my own question.. Thank you anyway :) How can I set your answer to be the best and close this "topic" ? – Philipp Oct 29 '12 at 18:57
you might be able to delete the question, or else head into the chat room and find a moderator who could close it- I'll flag it for moderator attention too; glad you got it fixed :) – cmhughes Oct 29 '12 at 19:52