Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I tried to install the emerald font package on my ubuntu natty box. However if I compile a minimal example like (emerald.tex)

\documentclass{article}

\usepackage{emerald}
\usepackage[T1]{fontenc}


\begin{document}
\ECFTeenSpirit
Hello World!
\end{document}

I get the following error

Running `LaTeX' on `emerald' with ``pdflatex --synctex=1 -interaction=nonstopmode "\input" emerald.tex''
This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009/Debian)
entering extended mode
LaTeX2e <2009/09/24>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang, nohyphenation, ngerman, german, german-x-2009-06-19, ngerman-x-2009-06-19, ibycus, monogreek, greek, ancientgreek, loaded.
(./emerald.tex (/usr/share/texmf-texlive/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/share/texmf-texlive/tex/latex/base/size10.clo))
(/home/myuser/texmf/tex/latex/emerald/emerald.sty)
(/usr/share/texmf-texlive/tex/latex/base/fontenc.sty
(/usr/share/texmf-texlive/tex/latex/base/t1enc.def)) (./emerald.aux)
(/home/myuser/texmf/tex/latex/emerald/t1fts.fd) [1{/home/myuser/.texmf-var/fonts/map/pdftex/updmap/pdftex.map}] (./emerald.aux) ) </home/myuser/.texmf-var/
fonts/pk/ljfour/jknappen/ec/ecrm1000.600pk>
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 ftsmdw8r
mktexpk: don't know how to create bitmap font for ftsmdw8r.
kpathsea: Appending font creation commands to missfont.log.

A locate ftsmdw8r gives me /home/myuser/texmf/fonts/tfm/emerald/ftsmdw8r.tfm.

Any idea how to fix this?

Here are the steps I did for the installation:

cd ~/texmf
wget http://mirror.ctan.org/fonts/emerald.zip
unzip emerald.zip
cd emerald 
cp -r tex/* ../tex/
cp -r fonts/* ../fonts/    
texhash $HOME/texmf
sudo updmap-sys --enable Map=emerald.map
share|improve this question
add comment

1 Answer

up vote 13 down vote accepted

I've tried it with TeXlive 2012, and got it working with the following steps:

mkdir -p `kpsewhich --var-value=TEXMFHOME`
cd `kpsewhich --var-value=TEXMFHOME`
wget http://mirror.ctan.org/fonts/emerald.zip
unzip emerald.zip
cp -r emerald/. . && rm -rf emerald/
rm emerald.zip
updmap --enable Map emerald.map
texhash

If this doesn't work, there might be issues in creating the updmap config, try:

mkdir -p ~/.texmf-config/web2c
echo Map emerald.map >> ~/.texmf-config/web2c/updmap.cfg
updmap

Also check the emerald.map file can actually be found:

kpsewhich emerald.map
share|improve this answer
    
I could not install this unit in my Ubuntu. –  Regis da Silva Feb 9 '13 at 3:29
    
It works on my Mac OSX with MacTex installed as well. First, download the emerald zip file from ctan and unzip it. Second, copy the two dirs: fonts and tex to ~/Library/texmf/. Third, run the two command updmap and texhash as mentioned by @Silex. –  Causality Feb 17 at 19:24
    
Worked fine (on Ubuntu 13.04 and manually installed TeXLive); did have to sudo texhash, though. (In fact, sudo `which texhash` because TeXLive is not in root's PATH on my machine.) –  Raphael Jun 6 at 11:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.