TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having an unexpected problem with the authoryear-comp style in Biblatex. See this MWE:

\usepackage[autostyle=false, style=british]{csquotes}

    Author = {Joe Doe},
    Title = {My article's title},
    Journal = {My journal's title},
    Editor = {Ben Editor},
    URL = {http://webpage.com},



When I compile, instead of getting Doe 2012 when citing, I get the article's title.

enter image description here

Is there something (obvious) I'm forgetting here?

share|improve this question
Which error messages do you get? I have biblatex: conflicting options firstinits and uniquename=full ... Do you use biber or bibtex? – Kurt Oct 31 '12 at 0:16
I don't get any errors. If I remove firstinits=true, I don't get the warning you mention, but still get the citation wrong. I'm using Biber. – NVaughan Oct 31 '12 at 0:38
Which tex distribution and operating system do you use? Which version of biber and biblatex? You can add \listfiles before \documentclass to get this information (for biber version look into file .blg). – Kurt Oct 31 '12 at 1:05
up vote 5 down vote accepted

You're missing the year/date field in your bibliography entry.

share|improve this answer
That's right! As Biblatex's documentation explains, authoryear-comp requires both the author and the year field; otherwise it default citing the title. Thanks for noticing. – NVaughan Oct 31 '12 at 1:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.