Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How can I reduce vertical height of the \longtable. Note that all the document is double-spaced. I need the vertical spaces in the tables to be exactly adjusted as in the \tabular.

Example:

\documentclass[a4paper,oneside,11pt]{book}
\usepackage[english]{babel}
\usepackage[super]{natbib}
\usepackage[LGR,T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsthm}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{delarray}
\usepackage{a4}
\usepackage{bbm}
\usepackage{epic}
\usepackage{eepic}
\usepackage{ecltree}
\usepackage{multicol}
\usepackage{indentfirst}
\usepackage{eurosym}
\usepackage{theorem}
\usepackage{graphicx}
\usepackage{fancyhdr}
\usepackage{vmargin}
\usepackage{rotating}
\usepackage{supertabular}
\usepackage{longtable}
\usepackage{array}
\usepackage{caption}
\usepackage{pgf}
\usepackage{float}
\usepackage{subfig}
\usepackage[dvips]{color}    
\usepackage{mathenv}
\usepackage{setspace}
\usepackage{subeqnarray}
\usepackage[norule]{footmisc}
\usepackage{enumerate}
\usepackage{lscape}
\usepackage{tikz}
\usepackage[toc,page]{appendix}
\usepackage[pdftex]{hyperref}
\hypersetup{colorlinks,citecolor=black,filecolor=black,linkcolor=black,urlcolor=black}

\pagestyle{fancy} \fancyhf{}

\renewcommand{\headrulewidth}{0.5pt}
\addtolength{\headheight}{0cm}

\setlength{\doublerulesep}{\arrayrulewidth}
\setlength\unitlength{0.5cm}


\lhead[\fancyplain{}{\thepage}]{\fancyplain{}{ \scriptsize
\leftmark}} \rhead[\fancyplain{}{ \scriptsize
\leftmark}]{\fancyplain{}{\thepage}}

\renewcommand{\baselinestretch}{2}

\setmarginsrb{3cm}{3cm}{3cm}{3cm}{1cm}{1cm}{2cm}{0cm}
\makeindex % Composer l'index de fin de document.0

\bibliographystyle{authordate1} % Définit le style de la bibliographie
\setlength{\doublerulesep}{\arrayrulewidth} \makeatletter
\renewcommand\@makefntext[1]
{\noindent\makebox[2em][r]{\@thefnmark.\,}#1} \makeatother
\makeatletter

\renewcommand*{\@seccntformat}[1]{
\csname the#1\endcsname.\quad} \makeatother
\renewcommand {\theenumi}{\roman{enumi}}


\begin{document}
\scriptsize\begin{longtable}{lccc|ccc}  
%
\centering 
\caption{abc} \label{tab:result1}\\
\hline
%
& \multicolumn{3}{c|}{\textbf{1}} & \multicolumn{3}{c}{\textbf{2}}  \\%
VARIABLES & a & b & c & a & b & c  \\
\hline
\endfirsthead
%
\multicolumn{7}{c}
%
{{\textbf{Table} \thetable\ -- \textit{Continued from previous page}}} \\
\hline \noalign{\vskip-3pt}
%
& \multicolumn{3}{c|}{\textbf{1}} & \multicolumn{3}{c}{\textbf{2}}  \\%
VARIABLES & a & b & c & a & b & c  \\
\hline
\endhead
%
\textit{Continued on next page} \\
\endfoot
%
\hline
\endlastfoot

1 & 2 & 3 & 4 & 5 & 6 & 7 \\
1 & 2 & 3 & 4 & 5 & 6 & 7 \\
1 & 2 & 3 & 4 & 5 & 6 & 7 \\
1 & 2 & 3 & 4 & 5 & 6 & 7 \\
1 & 2 & 3 & 4 & 5 & 6 & 7 \\
1 & 2 & 3 & 4 & 5 & 6 & 7 \\
1 & 2 & 3 & 4 & 5 & 6 & 7 \\
1 & 2 & 3 & 4 & 5 & 6 & 7 \\
1 & 2 & 3 & 4 & 5 & 6 & 7 \\

\end{longtable}
\end{document}
share|improve this question
1  
It would be helpful if you composed a fully compilable MWE including \documentclass and the appropriate packages that sets up the problem. While solving problems is fun, setting them up is not. Then those trying to help can simply cut and paste your MWE and get started on solving problem. This will also clarify if there are any issues that might be due to your preamble. –  Peter Grill Oct 31 '12 at 3:31
    
I don't know precisely the package or the commands for double spacing in the document, this is why I posted it all. Apologies for making it long –  Irene Oct 31 '12 at 3:45
    
Thanks, that certainly helps. But as it is, it does not compile for me due to an option clash. Please fix that. But, also you really should make an attempt at reducing it. Keep removing packages and see if the problem still shows up, until you have removed most of them. –  Peter Grill Oct 31 '12 at 4:00
1  
Irene, you use \usepackage{setspace} and \renewcommand{\baselinestretch}{2}. Delete the latter and use the setspace variant. –  Speravir Oct 31 '12 at 4:01
    
Thanks Peter, Maybe because it is a thesis code and the table I mention is inside a chapter. Speravir, Yes you are right, I tried \doublespacing instead of \renewcommand{\baselinestretch}{2} but still the vertical spaces in the \longtable huge . –  Irene Oct 31 '12 at 12:54

1 Answer 1

The idea of making a MWE is that you remove all the packages that are not relevant, your MWE isn't at all minimal.

It also generates two errors

! LaTeX Error: Option clash for package color.

and

! Misplaced \noalign.
\caption ->\noalign 

The latter is particular serious. longtable has no chance to generate correct spacing if given invalid input.

If you change your input to comment out the spurious lines

  %\usepackage[dvips]{color}    

and

 %\centering 

Then the document runs without error.

If the output is not as you wish you will need to clarify what you do want the output to be.


If you don't want the table double spaced you could use the cpmmands from teh setspace package or simply

\renewcommand{\baselinestretch}{1}

before the table.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.