Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like to use the JD font in LaTeX documents. When I try to typeset the following example

\documentclass{article}

\usepackage{emerald}
\usepackage[T1]{fontenc}

\begin{document}

Words. {\ECFJD More words.}

\end{document}

I get the error message

! Font T1/fjd/m/n/10=fjdmw8t at 10.0 pt not loadable: Metric (TFM) file not found.

I am using TeXShop on a Mac OS 10.6. I downloaded the zip file for the font at http://www.ctan.org/tex-archive/fonts/emerald/, and it is in the following directory: ~/Library/texmf/tex/latex. I don't know anything about installing fonts and assume I've done it wrong, but I have no idea how to make it work.

share|improve this question
1  
Welcome to TeX.SE. –  Peter Grill Nov 1 '12 at 0:04
    
A lot of TeX distributions (TeX Live for example) don't include the emerald fonts. Are you sure that your distribution does? –  Canageek Nov 1 '12 at 2:57
1  
You will have to put the files in the zip in the correct places. tfm e.g. should go to /texmf/fonts/tfm/emerald/. Check your main texmf tree for the various file types. Run texhash after you have moved the files. At the end you will have to enable the map, probably with updmap-sys --enable emerald.map. –  Ulrike Fischer Nov 1 '12 at 11:49
    
Thanks for your help--I didn't realize I had to run some commands in Terminal. In case this helps anyone else, here were the three things I did which made this work: create the string of folders local/texlive/texmf-local in my user folder; copy all files inside the unzipped Emerald folder into this texmf-local folder; and run the following in Terminal: texhash followed by sudo -H updmap-sys --enable Map=emerald.map followed by texhash again. The font is now functional! –  Annie Carter Nov 8 '12 at 3:16
    
@canageek: emerald shouldn't be in any tex distribution, given that the fonts don't all have the same licence (or they were when i was classifying the bindle for the ctan catalogue). –  wasteofspace Dec 1 '12 at 22:58

1 Answer 1

You can get the font working by placing it into your local texmf directory: Copy all files inside the unzipped Emerald folder into local/texlive/texmf-local in your user folder. If this folder is not existent, you can simply create it. Then run the following in Terminal: texhash followed by sudo -H updmap-sys --enable Map=emerald.map followed by texhash again. The font should now be functional!

share|improve this answer
    
Awesome. Are there any resources you could point me to to better understand what's going on with those magical commands? Thanks! –  Will Nov 14 '13 at 21:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.