TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using XeTeX to mimic another document, but I only have a similar font which I stretch using the extend and letterspace options.

My main problem is though, that my font's spaces (U+0020) are only about half as wide as the original font's. I don't want to use U+2000 to U+200A, because I want to be able to change the exact width without re-editing everything. I defined


But that's very verbose to use: Hello\K{}World

What I'd really like is an option that allows me to define a factor to stretch spaces by (it may disable TeX's automatic stretching, I don't use justified text or even automatic line breaks anyway), but I only found those for vertical spaces…

This works with pdflatex but not with my versions (3.1415926-2.2-0.9995.2 TeX Live 2009/Debian and 0.9997.4 TeX Live 2010) of xelatex. So a solution not using microtype would be nice…


\DeclareMicrotypeSet*[tracking]{my}{font = */*/*/*/*}
\SetTracking[spacing={1000,,}]{font = */*/*/*/*}{1}

share|improve this question
I don't relly understand how the "texlive" tag is relevant here. The question would be the same with MikTeX, for example. – mpg Jan 1 '11 at 12:58
I thought it was a problem with my XeTeX version, since updating to TeX Live 2010 solved another fontspec-related problem for me, but I remove the tag now – pascal Jan 2 '11 at 14:57
up vote 4 down vote accepted

In the case of pdflatex you can change \spaceskip (affects all fonts) or \fontdimen2 (affects only one font). In the case of xelatex: look up in the documentation of fontspec - section "interword space" - the option WordSpace.

share|improve this answer
Great, thanks. Fontspec also supports the other options I used with plain \font: FakeBold=embolden, FakeStretch=extend, LetterSpace=letterspace (but with different units, for some reason) – pascal Jan 2 '11 at 15:01

package microtype knows the \textls comamnd

share|improve this answer
I seem to have an issue with \textls and TikZ: ! Undefined control sequence. \tikz@invoke@collected@onpath ...mmand \tikz@temp[HERE] \pgf@stop \tikz@node@is@a@... but my line spacing has a problem, too, so I think that's unrelated. Thanks! – pascal Dec 30 '10 at 20:52
give a complete example, not only fragments – Herbert Dec 30 '10 at 20:55
Solved that problem now, but I now have found out that spacing doesn't seem to work with XeTeX: (see question) When compiled using pdflatex spaces are double wide, but there's no effect using xelatex. I see that they are just now implementing it, back to LaTeX then… – pascal Dec 31 '10 at 12:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.